major target cleanup. it is now possible to have subtargets that can override many...
[openwrt/staging/florian.git] / target / linux / brcm-2.4 / Makefile
index 14b73f8f5cdbcd1a2ab0efea35bba648375f9b56..da5cf6404f3718498fee8e33945900d41abac3ed 100644 (file)
@@ -6,16 +6,23 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+ARCH:=mipsel
+BOARD:=brcm-2.4
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs
 
-include ./config
-include $(INCLUDE_DIR)/kernel-build.mk
+KERNEL:=2.4
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram 
+
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+endef
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildTarget))