major target cleanup. it is now possible to have subtargets that can override many...
[openwrt/staging/florian.git] / target / linux / brcm-2.4 / Makefile
index 226da5623e87a7f6ef7d671df1ae4c07a5da5223..da5cf6404f3718498fee8e33945900d41abac3ed 100644 (file)
@@ -7,79 +7,22 @@
 include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
-BOARD:=brcm
+BOARD:=brcm-2.4
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs
 
-define Target/Description
-       Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
-endef
-
-LINUX_VERSION:=2.4.33.4
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
-
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch nvram
-
-define Profile/Broadcom
-  NAME:=Generic, Broadcom WiFi (default)
-  PACKAGES:=kmod-brcm-wl 
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/BroadcomMimo
-  NAME:=Generic, Broadcom WiFi (MIMO)
-  PACKAGES:=kmod-brcm-wl-mimo
-endef
-$(eval $(call Profile,BroadcomMimo))
-
-define Profile/Atheros
-  NAME:=Generic, Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/None
-  NAME:=Generic, No WiFi
-  PACKAGES:=
-endef
-$(eval $(call Profile,None))
-
-
-define Profile/WRT54G3G
-  NAME:=Linksys WRT54G3G
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt
-endef
-$(eval $(call Profile,WRT54G3G))
+KERNEL:=2.4
 
-define Profile/WL500G
-  NAME:=ASUS WL-500g
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp
-endef
-$(eval $(call Profile,WL500G))
+include $(INCLUDE_DIR)/target.mk
 
-define Profile/WL500GD
-  NAME:=ASUS WL-500g Deluxe
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2
-endef
-$(eval $(call Profile,WL500GD))
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram 
 
-define Profile/WL500GP
-  NAME:=ASUS WL-500g Premium
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
 endef
-$(eval $(call Profile,WL500GP))
 
-define Profile/WLHDD
-  NAME:=WL-HDD
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx
-endef
-$(eval $(call Profile,WLHDD))
+# include the profiles
+-include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))