major target cleanup. it is now possible to have subtargets that can override many...
[openwrt/staging/florian.git] / target / linux / brcm-2.4 / Makefile
index 3158d497afc4a0e6ad000f4d17bc49108c2199df..da5cf6404f3718498fee8e33945900d41abac3ed 100644 (file)
@@ -7,21 +7,22 @@
 include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
-BOARD:=brcm
+BOARD:=brcm-2.4
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs
 
+KERNEL:=2.4
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram 
+
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
 endef
 
-KERNEL:=2.4
-
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
-
 # include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))