use the default kernel target on powerpc
[openwrt/staging/florian.git] / target / linux / magicbox / patches / 100-cf_slot.patch
index ca7ca4e6216264c4392f0f4a37c9c3288aa82770..c37497342e9b4cf149a5f80d1abb5043495c4b19 100644 (file)
@@ -1,35 +1,11 @@
-Index: linux-2.6.24.7/drivers/ide/ide.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/ide.c
-+++ linux-2.6.24.7/drivers/ide/ide.c
-@@ -1563,6 +1563,7 @@ done:
- extern void __init pnpide_init(void);
- extern void __exit pnpide_exit(void);
- extern void __init h8300_ide_init(void);
-+extern void __init ide_magicbox_init(void);
- /*
-  * probe_for_hwifs() finds/initializes "known" IDE interfaces
-@@ -1627,6 +1628,9 @@ static void __init probe_for_hwifs (void
- #ifdef CONFIG_H8300
-       h8300_ide_init();
- #endif
-+#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
-+      ide_magicbox_init();
-+#endif
- }
- /*
-Index: linux-2.6.24.7/drivers/ide/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/Kconfig
-+++ linux-2.6.24.7/drivers/ide/Kconfig
-@@ -1018,6 +1018,14 @@ config BLK_DEV_MPC8xx_IDE
+--- a/drivers/ide/Kconfig
++++ b/drivers/ide/Kconfig
+@@ -928,6 +928,14 @@ config BLK_DEV_MPC8xx_IDE
  
          If unsure, say N.
  
 +config BLK_DEV_MAGICBOX_IDE
-+      bool "MagicBox 2.0 CF IDE support"
++      tristate "MagicBox 2.0 CF IDE support"
 +      depends on 4xx && IDE
 +      help
 +        This option provides support for IDE on MagicBox 2.0 boards.
@@ -39,15 +15,10 @@ Index: linux-2.6.24.7/drivers/ide/Kconfig
  choice
        prompt "Type of MPC8xx IDE interface"
        depends on BLK_DEV_MPC8xx_IDE
-Index: linux-2.6.24.7/drivers/ide/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/ide/Makefile
-+++ linux-2.6.24.7/drivers/ide/Makefile
-@@ -37,6 +37,7 @@ ide-core-$(CONFIG_BLK_DEV_Q40IDE)    += leg
- # built-in only drivers from ppc/
- ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
- ide-core-$(CONFIG_BLK_DEV_IDE_PMAC)   += ppc/pmac.o
-+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE)       += ppc/magicbox_ide.o
+--- a/drivers/ide/ppc/Makefile
++++ b/drivers/ide/ppc/Makefile
+@@ -1,3 +1,4 @@
  
- # built-in only drivers from h8300/
- ide-core-$(CONFIG_IDE_H8300)          += h8300/ide-h8300.o
+ obj-$(CONFIG_BLK_DEV_IDE_PMAC)                += pmac.o
+ obj-$(CONFIG_BLK_DEV_MPC8xx_IDE)      += mpc8xx.o
++obj-$(CONFIG_BLK_DEV_MAGICBOX_IDE)    += magicbox_ide.o