Update default configuration to use profiles
[openwrt/staging/florian.git] / target / linux / ps3 / Makefile
index 3499d024bd39bbb49f3a28511848591feb722d5f..40f8059eafd25c9f8c6e1f94a6873f01a4914a0a 100644 (file)
@@ -8,27 +8,33 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ps3
-BOARDNAME:=Sony PlayStation 3
-LINUX_VERSION:=2.6.23
+BOARDNAME:=Sony PS3 Game Console
+MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+SUBTARGETS=petitboot
+
+LINUX_VERSION:=2.6.28.9
+
 KERNEL_CC:=
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build bootloader images for the Playstation 3
-endef
+       Build for the Sony PS3 Game Console
 
-# no patches required
-define Kernel/Prepare/ps3
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-endef
+       The OpenWRT build will create both a 1st stage PS3-Linux image
+       suitable for programming into the PS3 flash memory, and a 2nd
+       stage PS3-Linux image suitable for loading via bootloaders or
+       the kexec utility.
 
-define Kernel/Prepare
-       $(call Kernel/Prepare/ps3)
+       Enable the Petitboot package to build a PS3 bootloader.
 endef
 
-# include the profiles
-#-include profiles/*.mk
+ifeq ($(CONFIG_TARGET_ps3_petitboot),y)
+define Kernel/Patch
+# no patches required
+endef
+endif
 
 KERNELNAME:="zImage"
+
 $(eval $(call BuildTarget))