toolchain-headers: also copy asm-eva.h for mips(el) for 3.15+
[openwrt/staging/florian.git] / toolchain / kernel-headers / Makefile
index ca8a78ff162ea36e4ebee6472d266184b9a1e7a6..d93a1230c8e306b042ac48d248207f02b344ac15 100644 (file)
@@ -36,6 +36,7 @@ HOST_EXTRACFLAGS=
 LINUX_HAS_HEADERS_INSTALL:=y
 
 KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
+       HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
        ARCH=$(LINUX_KARCH) \
        CC="$(KERNEL_CC)" \
        CFLAGS="$(TARGET_CFLAGS)" \
@@ -56,6 +57,7 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
        $(CP) \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/asm.h \
                $(HOST_BUILD_DIR)/arch/mips/include/asm/regdef.h \
+               $(if $(call kernel_patchver_ge,3.15.0),$(HOST_BUILD_DIR)/arch/mips/include/asm/asm-eva.h) \
                $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
   endef
 endif
@@ -69,15 +71,6 @@ define Host/Configure/post/cris
        $(SED) '/#include <asm\/page\.h>/d' $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/user.h
 endef
 
-define Host/Configure/post/ubicom32
-       $(CP) \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/elf.h \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/user.h \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page.h \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page_offset.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
-endef
-
 define Host/Configure/post/mips
        $(call Host/Configure/lzma)
 endef