clean up / fix various Host/Clean templates in tools/
[openwrt/staging/florian.git] / tools / ccache / Makefile
index e8e85b442afc04f39c6852d44e5e1112ea2d247e..f19c9337fb2c8910dffe4859aa687e9c0b6403fa 100644 (file)
@@ -15,34 +15,31 @@ PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
 PKG_MD5SUM:=73c1ed1e767c1752dd0f548ec1e66ce7
 PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/host-build.mk
 
 ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Build/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+  define Host/Compile
+       $(MAKE) CC="$(HOSTCC)" -C $(HOST_BUILD_DIR)
   endef
 
-  define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(STAGING_DIR)" \
-               install
+  define Host/Install
+       $(MAKE) -C $(HOST_BUILD_DIR) install
   endef
 
-  define Build/Clean
-       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Clean/Default)
+  define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
   endef
 else
-  define Build/Prepare
+  define Host/Prepare
+  endef
+  define Host/Configure
   endef
-  define Build/Configure
+  define Host/Compile
   endef
-  define Build/Compile
+  define Host/Install
   endef
-  define Build/Clean
+  define Host/Clean
   endef
 endif