avoid using implicit rules during metadata dump to speed up the process even more
[openwrt/staging/florian.git] / tools / sstrip / Makefile
index e861a4bfeaa89a8125e2305c181d08ade8e6d2b3..d93e7618d14200f4da565a9b0c9baaaeecd47c4d 100644 (file)
@@ -5,28 +5,21 @@
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host-build.mk
 
 PKG_NAME:=sstrip
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
 
-OS:=$(shell uname)
-ifeq ($(HOST_OS),Darwin)
-  CFLAGS += -I./include
-endif
-CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
+include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Compile
-       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+define Host/Compile
+       $(CC) $(HOST_CFLAGS) -I./include -include endian.h -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
 endef
 
-define Build/Install
-       mkdir -p $(STAGING_DIR)/bin
-       $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR)/bin/
+define Host/Install
+       $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
 endef
 
-define Build/Clean
-       rm -f $(STAGING_DIR)/bin/sstrip
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/sstrip
 endef
 
 $(eval $(call HostBuild))