add an "Installed-Size" field to package control files, so that opkg could check...
authorNicolas Thill <nico@openwrt.org>
Thu, 11 Dec 2008 20:15:41 +0000 (20:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 11 Dec 2008 20:15:41 +0000 (20:15 +0000)
SVN-Revision: 13602

include/package-ipkg.mk

index c5d4916c2cd59f0ed2a3a0e8761a72d7d28abee2..b91a27710bd55f505474df75482a3537af221697 100644 (file)
@@ -72,6 +72,7 @@ ifeq ($(DUMP),)
                echo "Priority: $(PRIORITY)"; \
                echo "Maintainer: $(MAINTAINER)"; \
                echo "Architecture: $(PKGARCH)"; \
+               echo "Installed-Size: 1"; \
                echo -n "Description: "; getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
        ) >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
@@ -84,6 +85,8 @@ ifeq ($(DUMP),)
        mkdir -p $(PACKAGE_DIR)
        -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
        $(RSTRIP) $$(IDIR_$(1))
+       SIZE=`cd $$(IDIR_$(1)); du -bs --exclude=./CONTROL . 2>/dev/null | cut -f1`; \
+       $(SED) "s|^\(Installed-Size:\).*|\1 $$$$SIZE|g" $$(IDIR_$(1))/CONTROL/control
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false