kernel patch: remove pcmcia compatibility crap - doesn't run on freebsd
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 20:33:55 +0000 (20:33 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 20:33:55 +0000 (20:33 +0000)
SVN-Revision: 5036

openwrt/target/linux/generic-2.4/patches/051-remove_pcmcia_modinst_compat.patch [new file with mode: 0644]

diff --git a/openwrt/target/linux/generic-2.4/patches/051-remove_pcmcia_modinst_compat.patch b/openwrt/target/linux/generic-2.4/patches/051-remove_pcmcia_modinst_compat.patch
new file mode 100644 (file)
index 0000000..091e4ba
--- /dev/null
@@ -0,0 +1,21 @@
+--- linux.old/Makefile Tue Oct 10 22:24:41 2006
++++ linux.dev/Makefile Tue Oct 10 22:26:19 2006
+@@ -427,17 +427,8 @@
+ depmod_opts   := -b $(INSTALL_MOD_PATH) -r
+ endif
+ .PHONY: _modinst_post
+-_modinst_post: _modinst_post_pcmcia
++_modinst_post:
+       if [ -r System.map ]; then $(DEPMOD) -ae -F System.map $(depmod_opts) $(KERNELRELEASE); fi
+-
+-# Backwards compatibilty symlinks for people still using old versions
+-# of pcmcia-cs with hard coded pathnames on insmod.  Remove
+-# _modinst_post_pcmcia for kernel 2.4.1.
+-.PHONY: _modinst_post_pcmcia
+-_modinst_post_pcmcia:
+-      cd $(MODLIB); \
+-      mkdir -p pcmcia; \
+-      find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia
+ .PHONY: $(patsubst %, _modinst_%, $(SUBDIRS))
+ $(patsubst %, _modinst_%, $(SUBDIRS)) :