ipset: use a common DEPENDS for both ipset and kmod-ipset packages
authorNicolas Thill <nico@openwrt.org>
Wed, 23 Dec 2009 09:32:45 +0000 (09:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 23 Dec 2009 09:32:45 +0000 (09:32 +0000)
SVN-Revision: 18902

package/ipset/Makefile

index b2095d668fde5175e0c0f9689a4745c4c3192b14..e7870c558529e78f784a0f093dade3949d33e8f0 100644 (file)
@@ -18,10 +18,15 @@ PKG_MD5SUM:=d104007fdf5ea64fef774c22b1c0a97b
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/ipset/Default
+  DEPENDS:= @LINUX_2_6
+endef
+
 define Package/ipset
+$(call Package/ipset/Default)
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:= @LINUX_2_6 +iptables-mod-ipset +kmod-ipt-ipset
+  DEPENDS+= +iptables-mod-ipset +kmod-ipt-ipset
   TITLE:=IPset administration utility
   URL:=http://ipset.netfilter.org/
 endef
@@ -67,9 +72,10 @@ define Package/ipset/install
 endef
 
 define KernelPackage/ipt-ipset
+$(call Package/ipset/Default)
   SUBMENU:=Netfilter Extensions
   TITLE:=IPset netfilter modules
-  DEPENDS:= @LINUX_2_6 kmod-ipt-core
+  DEPENDS+= kmod-ipt-core
   FILES:=$(foreach mod,$(IPSET_MODULES),$(PKG_BUILD_DIR)/kernel/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,46,$(IPSET_MODULES))
 endef