add option for cleaning all ipkg info before the image build
authorFelix Fietkau <nbd@openwrt.org>
Fri, 5 Oct 2007 21:52:05 +0000 (21:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 5 Oct 2007 21:52:05 +0000 (21:52 +0000)
SVN-Revision: 9151

Config.in
package/Makefile

index ce226e09f4bef48459139d95a2d43c7dc88ac4da..34d82492e7ffdfc28bf0d2c1a7e7c93eb631d216 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -80,14 +80,22 @@ menuconfig DEVEL
        select TOOLCHAINOPTS if !NATIVE_TOOLCHAIN
 
 config BROKEN
        select TOOLCHAINOPTS if !NATIVE_TOOLCHAIN
 
 config BROKEN
-       bool "Show broken platforms / packages" if DEVEL
+       bool
+       prompt "Show broken platforms / packages" if DEVEL
        default n
 
 config LOCALMIRROR
        default n
 
 config LOCALMIRROR
-       string "Local mirror for source packages" if DEVEL
+       string
+       prompt "Local mirror for source packages" if DEVEL
 
 menuconfig BUILDOPTS
 
 menuconfig BUILDOPTS
-       bool "Build Options" if DEVEL
+       bool
+       prompt "Build Options" if DEVEL
+
+config CLEAN_IPKG
+       bool
+       prompt "Clean all ipkg files before building the rootfs" if BUILDOPTS
+       default n
 
 config AUTOREBUILD
        bool
 
 config AUTOREBUILD
        bool
index aa059a7d23b7f8f3d7d36aba9543b46c6d433cff..1df4537dbadcc34c425c94e8815362e6d00b158a 100644 (file)
@@ -35,6 +35,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
+       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
 
 $(curdir)/index: FORCE
        @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
 
 $(curdir)/index: FORCE
        @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)