change OS to HOST_OS
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 19:19:24 +0000 (19:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 19:19:24 +0000 (19:19 +0000)
SVN-Revision: 5030

openwrt/tools/mtd-utils/Makefile
openwrt/tools/sstrip/Makefile

index f67ccf758fb4fc2bd8e0b483d4fb00d8ad15b10f..bc15f0a67193d9b43b03199d92dfaacecaba1aa4 100644 (file)
@@ -19,7 +19,7 @@ PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
 include $(INCLUDE_DIR)/host-build.mk
 
 CFLAGS := $(HOSTCFLAGS) -O2 -I../include
-ifneq ($(OS),Linux)
+ifneq ($(HOST_OS),Linux)
 CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h -include endian.h
 endif
 
index dc3ff4f6da5cc8405222c01c955e6c7549240ec9..4e409e0d8dc598d270a1d80de7971a44e6e919fc 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/host-build.mk
 PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
 
 OS:=$(shell uname)
-ifeq ($(OS),Darwin)
+ifeq ($(HOST_OS),Darwin)
   CFLAGS += -I./include
 endif