add back marvell switch support to 2.6.28
authorFelix Fietkau <nbd@openwrt.org>
Sun, 22 Mar 2009 20:18:05 +0000 (20:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 22 Mar 2009 20:18:05 +0000 (20:18 +0000)
SVN-Revision: 14974

target/linux/generic-2.6/patches-2.6.28/660-phy_mvswitch.patch [new file with mode: 0644]

diff --git a/target/linux/generic-2.6/patches-2.6.28/660-phy_mvswitch.patch b/target/linux/generic-2.6/patches-2.6.28/660-phy_mvswitch.patch
new file mode 100644 (file)
index 0000000..29b9c31
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -77,6 +77,9 @@ config ADM6996_PHY
+       ---help---
+         Currently supports the ADM6996F switch
++config MVSWITCH_PHY
++      tristate "Driver for Marvell 88E6060 switches"
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_VITESSE_PHY)    += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY)    += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o