mkimage: update to 2014.10
authorLuka Perkov <luka@openwrt.org>
Sat, 29 Nov 2014 22:43:59 +0000 (22:43 +0000)
committerLuka Perkov <luka@openwrt.org>
Sat, 29 Nov 2014 22:43:59 +0000 (22:43 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 43428

tools/mkimage/Makefile
tools/mkimage/patches/020-include_compile_fix.patch [new file with mode: 0644]
tools/mkimage/patches/020-openbsd_fixes.patch [deleted file]
tools/mkimage/patches/040-include_order.patch
tools/mkimage/patches/050-image_h_portability.patch
tools/mkimage/patches/060-remove_kernel_includes.patch

index 49eb26184d81daffe698086e35b2f46106b5ca65..2de13ab77b1456ec057913b282cbde24e0523789 100644 (file)
@@ -7,11 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2014.07
+PKG_VERSION:=2014.10
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
+PKG_SOURCE_URL:=\
+       http://mirror2.openwrt.org/sources \
+       ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
 PKG_CAT:=bzcat
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -29,6 +31,7 @@ define Host/Prepare
 endef
 
 define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) defconfig
        $(MAKE) -C $(HOST_BUILD_DIR) \
                HOSTLDFLAGS="$(HOST_STATIC_LINKING)" \
                tools-only
diff --git a/tools/mkimage/patches/020-include_compile_fix.patch b/tools/mkimage/patches/020-include_compile_fix.patch
new file mode 100644 (file)
index 0000000..276cae0
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/include/u-boot/rsa-checksum.h
++++ b/include/u-boot/rsa-checksum.h
+@@ -7,7 +7,6 @@
+ #ifndef _RSA_CHECKSUM_H
+ #define _RSA_CHECKSUM_H
+-#include <errno.h>
+ #include <image.h>
+ #include <u-boot/sha1.h>
+ #include <u-boot/sha256.h>
diff --git a/tools/mkimage/patches/020-openbsd_fixes.patch b/tools/mkimage/patches/020-openbsd_fixes.patch
deleted file mode 100644 (file)
index 7a762d9..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/tools/mkimage.c
-+++ b/tools/mkimage.c
-@@ -458,6 +458,7 @@
- #if defined(_POSIX_SYNCHRONIZED_IO) && \
-    !defined(__sun__) && \
-    !defined(__FreeBSD__) && \
-+   !defined(__OpenBSD__) && \
-    !defined(__APPLE__)
-       (void) fdatasync (ifd);
- #else
-@@ -501,6 +502,7 @@
- #if defined(_POSIX_SYNCHRONIZED_IO) && \
-    !defined(__sun__) && \
-    !defined(__FreeBSD__) && \
-+   !defined(__OpenBSD__) && \
-    !defined(__APPLE__)
-       (void) fdatasync (ifd);
- #else
index 66f703c85554c0882113569a4d2aee9da24a90ae..3b9ecc6bd3e4889573175ceb83914fb5abb4579b 100644 (file)
@@ -1,10 +1,10 @@
 --- a/tools/Makefile
 +++ b/tools/Makefile
-@@ -193,7 +193,7 @@
+@@ -194,7 +194,7 @@ endif # !LOGO_BMP
  # Define _GNU_SOURCE to obtain the getline prototype from stdio.h
  #
  HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
--              $(patsubst -I%,-idirafter%, $(UBOOTINCLUDE)) \
+-              $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
 +              -I$(srctree)/include \
                -I$(srctree)/lib/libfdt \
                -I$(srctree)/tools \
index 304a7aa24765d45229a3a05bd96e1dcf3916b0bb..b3ad27388c171f6b62e41480ba17693ddcc267bc 100644 (file)
@@ -8,7 +8,7 @@
  
  /* Define this to avoid #ifdefs later on */
  struct lmb;
-@@ -257,13 +256,13 @@
+@@ -258,13 +257,13 @@ struct lmb;
   * all data in network byte order (aka natural aka bigendian).
   */
  typedef struct image_header {
index 9462ca6aa8da79ed4211b3539529985b6c126ad2..fa533cd22d09ae077a5484b504dfe8d12a190aa8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/compiler.h
 +++ b/include/compiler.h
-@@ -53,6 +53,11 @@
+@@ -58,6 +58,11 @@ typedef uint8_t __u8;
  typedef uint16_t __u16;
  typedef uint32_t __u32;
  typedef unsigned int uint;
@@ -14,7 +14,7 @@
        ((((x) & 0xff00) >> 8) | \
 --- a/include/linux/posix_types.h
 +++ b/include/linux/posix_types.h
-@@ -43,6 +43,8 @@
+@@ -43,6 +43,8 @@ typedef void (*__kernel_sighandler_t)(in
  /* Type of a SYSV IPC key.  */
  typedef int __kernel_key_t;