kernel: remove gpio-pwm kmod definition
authorJonas Gorski <jogo@openwrt.org>
Wed, 19 Nov 2014 12:42:00 +0000 (12:42 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 19 Nov 2014 12:42:00 +0000 (12:42 +0000)
r37490 removed the actual driver but left the kmod definition intact,
causing the build system hapily creating an empty package for it.
Remove it also to not make it seem as if it still exists.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 43316

package/kernel/linux/modules/other.mk

index ce22819887ad24cbbdd0a7b6d9149acf33c8933b..5d1c2fb3486f7195441867569d974185f098ce37 100644 (file)
@@ -509,22 +509,6 @@ endef
 $(eval $(call KernelPackage,pwm))
 
 
-define KernelPackage/pwm-gpio
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=PWM over GPIO
-  DEPENDS:=+kmod-pwm
-  KCONFIG:=CONFIG_GPIO_PWM
-  FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
-  AUTOLOAD:=$(call AutoProbe,gpio-pwm)
-endef
-
-define KernelPackage/pwm-gpio/description
- Kernel module to models a single-channel PWM device using a timer and a GPIO pin
-endef
-
-$(eval $(call KernelPackage,pwm-gpio))
-
-
 define KernelPackage/rtc-ds1307
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support