move grub menu.lst to the right place
authorFelix Fietkau <nbd@openwrt.org>
Tue, 9 Oct 2007 16:57:12 +0000 (16:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 9 Oct 2007 16:57:12 +0000 (16:57 +0000)
SVN-Revision: 9216

package/grub/menu.lst [deleted file]
target/linux/x86/image/Makefile
target/linux/x86/image/menu.lst [new file with mode: 0644]

diff --git a/package/grub/menu.lst b/package/grub/menu.lst
deleted file mode 100644 (file)
index cb306cc..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-serial --unit=0 --speed=@BAUDRATE@ --word=8 --parity=no --stop=1
-terminal --timeout=2 console serial
-
-default 0
-timeout 5
-
-title   OpenWrt
-root    (hd0,0)
-kernel  /boot/vmlinuz @CMDLINE@ noinitrd console=tty0 console=ttyS0,@BAUDRATE@n8 reboot=bios
-boot
-
-title  OpenWrt (failsafe)
-root   (hd0,0)
-kernel  /boot/vmlinuz failsafe=true @CMDLINE@ noinitrd console=tty0 console=ttyS0,@BAUDRATE@n8 reboot=bios
-boot
index 095d40240ba7efc4b9e18693d3dbe6903b01ba82..dd147b869a952ab678af81cc16a38b8e01f4d466 100644 (file)
@@ -40,7 +40,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
        sed \
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
                -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
-               ./grub/menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
+               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
        PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
        $(call Image/Build/grub/$(1))
   endef
diff --git a/target/linux/x86/image/menu.lst b/target/linux/x86/image/menu.lst
new file mode 100644 (file)
index 0000000..cb306cc
--- /dev/null
@@ -0,0 +1,15 @@
+serial --unit=0 --speed=@BAUDRATE@ --word=8 --parity=no --stop=1
+terminal --timeout=2 console serial
+
+default 0
+timeout 5
+
+title   OpenWrt
+root    (hd0,0)
+kernel  /boot/vmlinuz @CMDLINE@ noinitrd console=tty0 console=ttyS0,@BAUDRATE@n8 reboot=bios
+boot
+
+title  OpenWrt (failsafe)
+root   (hd0,0)
+kernel  /boot/vmlinuz failsafe=true @CMDLINE@ noinitrd console=tty0 console=ttyS0,@BAUDRATE@n8 reboot=bios
+boot