find: use -follow instead of -L, some systems don't support -L
authorFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jul 2007 06:35:00 +0000 (06:35 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jul 2007 06:35:00 +0000 (06:35 +0000)
SVN-Revision: 8000

include/scan.mk

index a0ee1ad678e93f27d999830715ae91201dd8384e..04add4016c63f89f01fc56981ff77bed11f8296f 100644 (file)
@@ -31,7 +31,7 @@ endef
 
 $(FILELIST):
        rm -f tmp/info/.files-$(SCAN_TARGET)-*
-       find -L $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
+       find -follow $(SCAN_DIR) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
 
 tmp/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
        ( \