polarssl: update to version 1.3.18
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 3 Dec 2016 15:07:14 +0000 (16:07 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 3 Dec 2016 15:36:34 +0000 (16:36 +0100)
This fixes two minor security problems.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/libs/polarssl/Makefile
package/libs/polarssl/patches/200-reduce_config.patch

index 2f2029f9d8ea61c54e822a430302a346be6bfe3b..52c91dcca6d1a0453b5c85955ab000810138df62 100644 (file)
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=polarssl
 SRC_PKG_NAME:=mbedtls
-PKG_VERSION:=1.3.17
+PKG_VERSION:=1.3.18
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(SRC_PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=https://tls.mbed.org/download/
-PKG_MD5SUM:=f5beb43e850283915e3e0f8d37495eade3bfb5beedfb61e7b8da70d4c68edb82
+PKG_MD5SUM:=a229217182e024847deba3cb70bdd17e5ff4ffd9ff306cbbccfdbdff41950ea1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(SRC_PKG_NAME)-$(PKG_VERSION)
 
index 9e2734aa6c6cf81f1b23a0a981c0db37bcaaac1f..491ecec3886084d07b319b6ef01bae2c1d5b25f7 100644 (file)
@@ -99,8 +99,8 @@
 + */
  
  /**
-  * \def POLARSSL_SSL_AEAD_RANDOM_IV
-@@ -1151,8 +1151,8 @@
+  * \def POLARSSL_SSL_ALL_ALERT_MESSAGES
+@@ -1139,8 +1139,8 @@
   * Requires: POLARSSL_VERSION_C
   *
   * Comment this to disable run-time checking and save ROM space
  
  /**
   * \def POLARSSL_X509_ALLOW_EXTENSIONS_NON_V3
-@@ -1470,8 +1470,8 @@
+@@ -1469,8 +1469,8 @@
   *      TLS_PSK_WITH_CAMELLIA_256_CBC_SHA384
   *      TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256
   *      TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256
  
  /**
   * \def POLARSSL_CCM_C
-@@ -1498,8 +1498,8 @@
+@@ -1497,8 +1497,8 @@
   * Requires: POLARSSL_PEM_PARSE_C
   *
   * This module is used for testing (ssl_client/server).
  
  /**
   * \def POLARSSL_CIPHER_C
-@@ -1538,8 +1538,8 @@
+@@ -1537,8 +1537,8 @@
   *          library/ssl_tls.c
   *
   * This module provides debugging functions.
  
  /**
   * \def POLARSSL_DES_C
-@@ -1594,8 +1594,8 @@
+@@ -1593,8 +1593,8 @@
   *      ECDHE-ECDSA, ECDHE-RSA, DHE-PSK
   *
   * Requires: POLARSSL_ECP_C
  
  /**
   * \def POLARSSL_ECDSA_C
-@@ -1609,8 +1609,8 @@
+@@ -1608,8 +1608,8 @@
   *      ECDHE-ECDSA
   *
   * Requires: POLARSSL_ECP_C, POLARSSL_ASN1_WRITE_C, POLARSSL_ASN1_PARSE_C
  
  /**
   * \def POLARSSL_ECP_C
-@@ -1622,8 +1622,8 @@
+@@ -1621,8 +1621,8 @@
   *          library/ecdsa.c
   *
   * Requires: POLARSSL_BIGNUM_C and at least one POLARSSL_ECP_DP_XXX_ENABLED
  
  /**
   * \def POLARSSL_ENTROPY_C
-@@ -1699,8 +1699,8 @@
+@@ -1698,8 +1698,8 @@
   * Requires: POLARSSL_MD_C
   *
   * Uncomment to enable the HMAC_DRBG random number geerator.
  
  /**
   * \def POLARSSL_MD_C
-@@ -1826,8 +1826,8 @@
+@@ -1825,8 +1825,8 @@
   * Requires: POLARSSL_HAVE_ASM
   *
   * This modules adds support for the VIA PadLock on x86.
  
  /**
   * \def POLARSSL_PBKDF2_C
-@@ -1992,8 +1992,8 @@
+@@ -1991,8 +1991,8 @@
   * Module:  library/ripemd160.c
   * Caller:  library/md.c
   *
  
  /**
   * \def POLARSSL_RSA_C
-@@ -2072,8 +2072,8 @@
+@@ -2071,8 +2071,8 @@
   * Caller:
   *
   * Requires: POLARSSL_SSL_CACHE_C
  
  /**
   * \def POLARSSL_SSL_CLI_C
-@@ -2149,8 +2149,8 @@
+@@ -2148,8 +2148,8 @@
   * Caller:  library/havege.c
   *
   * This module is used by the HAVEGE random number generator.
  
  /**
   * \def POLARSSL_VERSION_C
-@@ -2160,8 +2160,8 @@
+@@ -2159,8 +2159,8 @@
   * Module:  library/version.c
   *
   * This module provides run-time version information.
  
  /**
   * \def POLARSSL_X509_USE_C
-@@ -2270,8 +2270,8 @@
+@@ -2269,8 +2269,8 @@
   *
   * Module:  library/xtea.c
   * Caller: