mcs814x: account for dtb output directory differences
authorFlorian Fainelli <florian@openwrt.org>
Sat, 10 Jan 2015 20:11:18 +0000 (20:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 10 Jan 2015 20:11:18 +0000 (20:11 +0000)
3.3 produced *.dtb files in arch/arm/boot/ while 3.14 will produce those
in arch/arm/boot/dts/, adjust the image makefile accordingly.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 43925

target/linux/mcs814x/image/Makefile

index 1c814fa4fd56a462b1f1bd1f44b0e0f3b154d5a7..7f8722d6bd9a64a5da9574a52dc1c1c9d842f216 100644 (file)
@@ -9,6 +9,12 @@ include $(INCLUDE_DIR)/image.mk
 
 TARGET_DTBS := rbt-832 dlan-usb-extender
 
+ifeq ($(KERNEL_PATCHVER),3.3)
+DTBS_DIR:=
+else
+DTBS_DIR:=dts/
+endif
+
 LOADADDR:=0x00008000
 
 JFFS2_BLOCKSIZE = 128k
@@ -22,7 +28,7 @@ endef
 
 define Image/Build/DTB
        cp $(KDIR)/zImage$(2) $(KDIR)/zImage-$(1);
-       cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
+       cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(DTBS_DIR)$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
        $(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
        cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
 endef