ramips: rt305x: add support for the DIR-600 B1,B2 boards
authorGabor Juhos <juhosg@openwrt.org>
Thu, 28 Jul 2011 10:56:24 +0000 (10:56 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 28 Jul 2011 10:56:24 +0000 (10:56 +0000)
SVN-Revision: 27808

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-dir-300-revb.c
target/linux/ramips/image/Makefile

index f0bd63faec6eb821959b6523efc916d8d65403e7..c41105397a131a25d2fd4ec4ede52dc7a4f68c58 100755 (executable)
@@ -30,7 +30,7 @@ status_led_off() {
 
 get_status_led() {
        case $(ramips_board_name) in
-       dir-300-b1)
+       dir-300-b1 | dir-600-b1 | dir-600-b2)
                status_led="d-link:green:status"
                ;;
        fonera20n)
index 398ad79ecfd81bee41e9f352427026e5d8477a91..03ff4f81d4c2688c5b9824ec6ba61a7ba4f48edb 100644 (file)
@@ -31,7 +31,9 @@ case "$FIRMWARE" in
        local board=$(ramips_board_name)
 
        case $board in
-       dir-300-b1)
+       dir-300-b1 | \
+       dir-600-b1 | \
+       dir-600-b2)
                rt2x00_eeprom_extract "devdata" 16384 272
                ;;
 
index dc03b4755b16bf81b4be868524dce6f58789c0b4..f34454b6d8d9a67e535777c54bbba10fe4a3f2e8 100755 (executable)
@@ -16,6 +16,12 @@ ramips_board_name() {
        *"DIR-300 B1")
                name="dir-300-b1"
                ;;
+       *"DIR-600 B1")
+               name="dir-600-b1"
+               ;;
+       *"DIR-600 B2")
+               name="dir-600-b2"
+               ;;
        *"F5D8235 v2")
                name="f5d8235-v2"
                ;;
index b701938f25ecccbcf2bc9d2bda81bde5614facbf..0dd3b7bd236608c3b2d2df415b68998e31ac71c1 100755 (executable)
@@ -14,7 +14,7 @@ platform_check_image() {
        [ "$ARGC" -gt 1 ] && return 1
 
        case "$board" in
-       dir-300-b1 | fonera20n | v22rw-2x2 | whr-g300n | hw550-3g | mofi3500-3gn)
+       dir-300-b1 | dir-600-b1 | dir-600-b2 | fonera20n | v22rw-2x2 | whr-g300n | hw550-3g | mofi3500-3gn)
                [ "$magic" != "2705" ] && {
                        echo "Invalid image type."
                        return 1
index acaf604736b8261f54c5eff94efaa2a170ab041e..b9f8a602ee72ad1c7d93c12af6a33369e5bfe35a 100644 (file)
@@ -19,6 +19,8 @@ enum ramips_mach_type {
 
        /* RT3050 based machines */
        RAMIPS_MACH_DIR_300_B1,         /* D-Link DIR-300 B1 */
+       RAMIPS_MACH_DIR_600_B1,         /* D-Link DIR-600 B1 */
+       RAMIPS_MACH_DIR_600_B2,         /* D-Link DIR-600 B2 */
 
        /* RT3052 based machines */
        RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
index c0167bc03aff28cc877421aa647d518a2d6e98e5..71b9c51fa412fff84e34b77eaa8f7d4441728692 100644 (file)
@@ -122,3 +122,9 @@ static void __init dir_300b_init(void)
 
 MIPS_MACHINE(RAMIPS_MACH_DIR_300_B1, "DIR-300-B1", "D-Link DIR-300 B1",
             dir_300b_init);
+
+MIPS_MACHINE(RAMIPS_MACH_DIR_600_B1, "DIR-600-B1", "D-Link DIR-600 B1",
+            dir_300b_init);
+
+MIPS_MACHINE(RAMIPS_MACH_DIR_600_B2, "DIR-600-B2", "D-Link DIR-600 B2",
+            dir_300b_init);
index e84d4686094a5a1bc2f961ba4f51adc214b8bd67..dde5ca89ad7b3bbf7d32f466d5035c32acf96cac 100644 (file)
@@ -104,13 +104,15 @@ mtd_dir300b1_kernel_part_size=851968
 mtd_dir300b1_rootfs_part_size=3014656
 define Image/Build/Template/DIR300B1
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_dir300b1,$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
-       mkwrgimg -s wrgn23_dlwbr_dir300b -d /dev/mtdblock/2 \
+       mkwrgimg -s $(4) -d /dev/mtdblock/2 \
                -i $(call imgname,$(1),$(2))-sysupgrade.bin \
                -o $(call imgname,$(1),$(2))-factory.bin
 endef
 
 define Image/Build/Profile/DIR300B1
-       $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1)
+       $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
+       $(call Image/Build/Template/DIR300B1,$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
+       $(call Image/Build/Template/DIR300B1,$(1),dir-600-b2,DIR-600-B2,wrgn23_dlwbr_dir600b)
 endef
 
 define Image/Build/Profile/FONERA20N