toolchain: musl: fix symlink for ldd
authorJonas Gorski <jogo@openwrt.org>
Wed, 19 Nov 2014 12:17:34 +0000 (12:17 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 19 Nov 2014 12:17:34 +0000 (12:17 +0000)
ld-musl-*.so* is a symlink "broken" for the hostsystem, so wildcard
will skip it, causing LD_MUSL_NAME to empty and the ldd symlink pointing
to ../../lib directly.
This causes sysupgrade failing to copy any linked libaries and
consequently failing to run anything after switching to ram disk.

Fix this by creating a symlink directly pointing to where ld-musl-*.so*
points to.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 43314

package/libs/toolchain/Makefile

index 1cb83fa126bd03636ee092a4be5fca8f2b7dc226..10c990a12634dd3dc062544baa7521be7811355e 100644 (file)
@@ -466,7 +466,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
                $(1)/lib/
   endef
 
-  LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
+  LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/libc.so*)))
 
   define Package/musl/install
        $(INSTALL_DIR) $(1)/lib $(1)/usr/bin