brcm63xx: Add DT support for F@ST2504n
authorJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 00:51:08 +0000 (00:51 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 00:51:08 +0000 (00:51 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43450

target/linux/brcm63xx/dts/fast2504n.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/profiles/sagem.mk

diff --git a/target/linux/brcm63xx/dts/fast2504n.dts b/target/linux/brcm63xx/dts/fast2504n.dts
new file mode 100644 (file)
index 0000000..2f202a3
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6362.dtsi"
+
+/ {
+       model = "Sagem F@ST2504n";
+       compatible = "sagem,f@st2504n", "brcm,bcm6362";
+};
index 14d07309f7e0d89f15ebfdb171424d9fb78b050f..26063e9615444d9381db80488951e2a92441a56d 100755 (executable)
@@ -200,9 +200,6 @@ define Image/Build
        # RTA1320_16M (numerous routers)
        $(call Image/Build/CFE,$(1),RTA1320_16M,6338,RTA1320_16M,,--layoutver 5)
 
-       # Sagem F@ST2504n
-       $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
-
        # USR 9108
        $(call Image/Build/CFE,$(1),96348GW-A,6348,USR9108)
        # NetGear DG834GT, DG834PN
@@ -319,6 +316,8 @@ $(eval $(call ImageDTB,CFEDTB,A226M,a226m,DWV-S0,6358,A226M,--signature2 IMAGE -
 $(eval $(call ImageDTB,CFEDTB,A226M,a226m-fwb,DWV-S0,6358,A226M-FWB,--block-size 0x20000 --image-offset 0x20000 --signature2 IMAGE --tag-version 8))
 # Sagem F@ST2404
 $(eval $(call ImageDTB,CFEDTB,FAST2404,fast2404,F@ST2404,6348,F@ST2404))
+# Sagem F@ST2504n
+$(eval $(call ImageDTB,CFEDTB,FAST2504n,fast2504n,F@ST2504n,6362,F@ST2504n))
 # Sagem F@ST2604
 $(eval $(call ImageDTB,CFEDTB,FAST2604,fast2604,F@ST2604,6348,F@ST2604))
 # Sagem F@ST2704V2
index 27c83446cfed86273ee7ee362c4c8472dc1dc7a4..1b00d464eb70becd458999e8ffa625634182af93 100644 (file)
@@ -111,3 +111,11 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
+@@ -3738,6 +3829,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "t-com,spw303v", .data = &board_spw303v, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6362
++      { .compatible = "sagem,f@st2504n", .data = &board_fast2504n, },
+       { .compatible = "sfr,nb6-ser-r0", .data = &board_nb6, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6368
index 80ae8932f149ebf90b60a2cdae1bec6fc6c8e80a..5afb2b725915f56fdba1ed27c3ca2e6d9d842ece 100644 (file)
@@ -14,6 +14,15 @@ define Profile/FAST2404/Description
 endef
 $(eval $(call Profile,FAST2404))
 
+define Profile/FAST2504n
+  NAME:=Sagem F@ST2504n
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/FAST2504n/Description
+  Package set optimized for F@ST2504n.
+endef
+$(eval $(call Profile,FAST2504n))
+
 define Profile/FAST2604
   NAME:=Sagem F@ST2604
   PACKAGES:=kmod-b43 wpad-mini