siit: use $(KERNEL_MAKEOPTS)
authorNicolas Thill <nico@openwrt.org>
Sun, 7 Mar 2010 03:44:48 +0000 (03:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 7 Mar 2010 03:44:48 +0000 (03:44 +0000)
SVN-Revision: 20025

package/siit/Makefile

index 1eaaac356acade36f4bae3e03b6b4d785742e5f3..fc67d0d3c0ffff803b0939cfc229981fd8afbdf2 100644 (file)
@@ -21,6 +21,8 @@ define KernelPackage/siit
   AUTOLOAD:=$(call AutoLoad,50,siit)
 endef
 
+include $(INCLUDE_DIR)/kernel-defaults.mk
+
 define KernelPackage/siit/description
  Stateless IP ICMP Translation Algorithm
 endef
@@ -31,13 +33,7 @@ define Build/Prepare
 endef
 
 define Build/Compile
-       $(MAKE) -C $(LINUX_DIR) \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               ARCH="$(LINUX_KARCH)" \
-               SUBDIRS="$(PKG_BUILD_DIR)" \
-               KERNELDIR=$(LINUX_DIR) \
-               CC="$(TARGET_CC)" \
-               modules
+       $(MAKE) $(KERNEL_MAKEOPTS) M=$(PKG_BUILD_DIR) modules
 endef
 
 $(eval $(call KernelPackage,siit))