packages: more (e)glibc fixes after r44701
authorNicolas Thill <nico@openwrt.org>
Mon, 16 Mar 2015 12:32:22 +0000 (12:32 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 16 Mar 2015 12:32:22 +0000 (12:32 +0000)
_GNU_SOURCE has been declared "deprecated" in favor of _DEFAULT_SOURCE in glibc

Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 44843

package/network/services/uhttpd/Makefile
package/utils/ugps/Makefile

index 7c0989de1a520437fa402f70f826781e7ca18702..f4de987e659700db3c2f6d77f8b65a1a53305b6b 100644 (file)
@@ -107,6 +107,10 @@ define Package/uhttpd/conffiles
 /etc/uhttpd.key
 endef
 
+ifneq ($(CONFIG_USE_GLIBC),)
+  TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
 TARGET_LDFLAGS += -lcrypt
 
 CMAKE_OPTIONS = -DTLS_SUPPORT=on
index c1bc7cdd01af5607e436c74bdcb8522c74e7de31..3662125c3a26a5fa03e962d0ccc44e54db781a5e 100644 (file)
@@ -32,6 +32,10 @@ endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
 
+ifneq ($(CONFIG_USE_GLIBC),)
+  TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
 define Package/ugps/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/