brcm63xx: move generic profiles to top dir and remove smp profiles
authorJonas Gorski <jogo@openwrt.org>
Mon, 18 Aug 2014 21:50:37 +0000 (21:50 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 18 Aug 2014 21:50:37 +0000 (21:50 +0000)
Use generic profiles for brcm63xx instead of having similar profiles for
each subtarget.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42208

24 files changed:
target/linux/brcm63xx/generic/profiles/100-Broadcom.mk [deleted file]
target/linux/brcm63xx/generic/profiles/101-Broadcom-wl.mk [deleted file]
target/linux/brcm63xx/generic/profiles/102-Atheros.mk [deleted file]
target/linux/brcm63xx/generic/profiles/103-Ralink.mk [deleted file]
target/linux/brcm63xx/generic/profiles/104-No-WiFi.mk [deleted file]
target/linux/brcm63xx/generic/profiles/105-Broadcom-brcmsmac.mk [deleted file]
target/linux/brcm63xx/generic/profiles/200-GW6X00.mk [deleted file]
target/linux/brcm63xx/generic/profiles/201-Huawei.mk [deleted file]
target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk [deleted file]
target/linux/brcm63xx/profiles/100-Broadcom.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/101-Broadcom-wl.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/102-Atheros.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/103-Ralink.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/104-No-WiFi.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/105-Broadcom-brcmsmac.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/200-GW6X00.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/201-Huawei.mk [new file with mode: 0644]
target/linux/brcm63xx/profiles/202-Sagemcom.mk [new file with mode: 0644]
target/linux/brcm63xx/smp/profiles/100-Broadcom.mk [deleted file]
target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk [deleted file]
target/linux/brcm63xx/smp/profiles/102-Atheros.mk [deleted file]
target/linux/brcm63xx/smp/profiles/103-Ralink.mk [deleted file]
target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk [deleted file]
target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk [deleted file]

diff --git a/target/linux/brcm63xx/generic/profiles/100-Broadcom.mk b/target/linux/brcm63xx/generic/profiles/100-Broadcom.mk
deleted file mode 100644 (file)
index bc68f14..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom
-  NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-b43 wpad-mini
-endef
-
-define Profile/Broadcom/Description
-       Package set compatible with hardware using Broadcom WiFi cards
-endef
-$(eval $(call Profile,Broadcom))
-
diff --git a/target/linux/brcm63xx/generic/profiles/101-Broadcom-wl.mk b/target/linux/brcm63xx/generic/profiles/101-Broadcom-wl.mk
deleted file mode 100644 (file)
index 4f2d605..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-wl
-  NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
-  PACKAGES:= kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-wl/Description
-       Package set compatible with hardware using Broadcom BCM43xx cards
-       using the proprietary broadcom wireless "wl" driver.
-endef
-
-$(eval $(call Profile,Broadcom-wl))
-
diff --git a/target/linux/brcm63xx/generic/profiles/102-Atheros.mk b/target/linux/brcm63xx/generic/profiles/102-Atheros.mk
deleted file mode 100644 (file)
index b214185..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-ath5k kmod-ath9k wpad-mini
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
diff --git a/target/linux/brcm63xx/generic/profiles/103-Ralink.mk b/target/linux/brcm63xx/generic/profiles/103-Ralink.mk
deleted file mode 100644 (file)
index 412c5a4..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ralink
-  NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt61-pci wpad-mini
-endef
-$(eval $(call Profile,Ralink))
-
diff --git a/target/linux/brcm63xx/generic/profiles/104-No-WiFi.mk b/target/linux/brcm63xx/generic/profiles/104-No-WiFi.mk
deleted file mode 100644 (file)
index 9b59b17..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NoWiFi
-  NAME:=No WiFi (BCM6338)
-  PACKAGES:=
-endef
-
-define Profile/NoWiFi/description
-  Package set compatible with BCM63xx routers without Wi-Fi (e.g: BCM6338-based).
-endef
-
-$(eval $(call Profile,NoWiFi))
diff --git a/target/linux/brcm63xx/generic/profiles/105-Broadcom-brcmsmac.mk b/target/linux/brcm63xx/generic/profiles/105-Broadcom-brcmsmac.mk
deleted file mode 100644 (file)
index bb558d1..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-brcmsmac
-  NAME:=Broadcom WiFi (brcmsmac)
-  PACKAGES:=kmod-brcmsmac wpad-mini
-endef
-
-define Profile/Broadcom-brcmsmac/Description
-       Package set compatible with hardware using Broadcom WiFi cards
-endef
-$(eval $(call Profile,Broadcom-brcmsmac))
-
diff --git a/target/linux/brcm63xx/generic/profiles/200-GW6X00.mk b/target/linux/brcm63xx/generic/profiles/200-GW6X00.mk
deleted file mode 100644 (file)
index 1cb763d..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/GW6X00
-  NAME:=Tecom GW6X00
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb-storage \
-       kmod-fs-ext4 kmod-nls-cp437 kmod-nls-iso8859-1 e2fsprogs \
-       kmod-ipt-nathelper-extra wlc
-endef
-
-define Profile/GW6X00/Description
-       Package set compatible with the Tecom GW6000 and GW6200 based
-       on the BCM96348GW reference design.
-endef
-$(eval $(call Profile,GW6X00))
-
diff --git a/target/linux/brcm63xx/generic/profiles/201-Huawei.mk b/target/linux/brcm63xx/generic/profiles/201-Huawei.mk
deleted file mode 100644 (file)
index 820f5e0..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-#
-# Copyright (C) 2012-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/HW553
-  NAME:=Huawei HG553
-  PACKAGES:=kmod-b43 wpad-mini \
-       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
-endef
-define Profile/HW553/Description
-       Package set optimized for Huawei HG553 using open-source b43 WiFi driver
-endef
-$(eval $(call Profile,HW553))
-
-define Profile/HW556
-  NAME:=Huawei HG556a
-  PACKAGES:=kmod-rt2800-pci kmod-ath9k wpad-mini \
-       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
-endef
-define Profile/HW556/Description
-       Package set optimized for Huawei HG556a using open-source atheros or ralink WiFi driver
-endef
-$(eval $(call Profile,HW556))
diff --git a/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk b/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk
deleted file mode 100644 (file)
index ebe1755..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Sagemcom-2704V2
-  NAME:=Sagemcom F@ST 2704 V2
-  PACKAGES:=kmod-b43 wpad-mini \
-    kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev 
-endef
-define Profile/Sagemcom-2704V2/Description
-  Package set optimized for Sagemcom F@ST 2704 using open-source b43 WiFi driver
-endef
-$(eval $(call Profile,Sagemcom-2704V2))
diff --git a/target/linux/brcm63xx/profiles/100-Broadcom.mk b/target/linux/brcm63xx/profiles/100-Broadcom.mk
new file mode 100644 (file)
index 0000000..bc68f14
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+  NAME:=Broadcom WiFi (default)
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+
+define Profile/Broadcom/Description
+       Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk b/target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
new file mode 100644 (file)
index 0000000..4f2d605
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+  NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
+  PACKAGES:= kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+       Package set compatible with hardware using Broadcom BCM43xx cards
+       using the proprietary broadcom wireless "wl" driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm63xx/profiles/102-Atheros.mk b/target/linux/brcm63xx/profiles/102-Atheros.mk
new file mode 100644 (file)
index 0000000..b214185
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-ath5k kmod-ath9k wpad-mini
+endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm63xx/profiles/103-Ralink.mk b/target/linux/brcm63xx/profiles/103-Ralink.mk
new file mode 100644 (file)
index 0000000..412c5a4
--- /dev/null
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+  NAME:=Ralink WiFi
+  PACKAGES:=kmod-rt61-pci wpad-mini
+endef
+$(eval $(call Profile,Ralink))
+
diff --git a/target/linux/brcm63xx/profiles/104-No-WiFi.mk b/target/linux/brcm63xx/profiles/104-No-WiFi.mk
new file mode 100644 (file)
index 0000000..9b59b17
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NoWiFi
+  NAME:=No WiFi (BCM6338)
+  PACKAGES:=
+endef
+
+define Profile/NoWiFi/description
+  Package set compatible with BCM63xx routers without Wi-Fi (e.g: BCM6338-based).
+endef
+
+$(eval $(call Profile,NoWiFi))
diff --git a/target/linux/brcm63xx/profiles/105-Broadcom-brcmsmac.mk b/target/linux/brcm63xx/profiles/105-Broadcom-brcmsmac.mk
new file mode 100644 (file)
index 0000000..bb558d1
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-brcmsmac
+  NAME:=Broadcom WiFi (brcmsmac)
+  PACKAGES:=kmod-brcmsmac wpad-mini
+endef
+
+define Profile/Broadcom-brcmsmac/Description
+       Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom-brcmsmac))
+
diff --git a/target/linux/brcm63xx/profiles/200-GW6X00.mk b/target/linux/brcm63xx/profiles/200-GW6X00.mk
new file mode 100644 (file)
index 0000000..1cb763d
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/GW6X00
+  NAME:=Tecom GW6X00
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb-storage \
+       kmod-fs-ext4 kmod-nls-cp437 kmod-nls-iso8859-1 e2fsprogs \
+       kmod-ipt-nathelper-extra wlc
+endef
+
+define Profile/GW6X00/Description
+       Package set compatible with the Tecom GW6000 and GW6200 based
+       on the BCM96348GW reference design.
+endef
+$(eval $(call Profile,GW6X00))
+
diff --git a/target/linux/brcm63xx/profiles/201-Huawei.mk b/target/linux/brcm63xx/profiles/201-Huawei.mk
new file mode 100644 (file)
index 0000000..820f5e0
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2012-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HW553
+  NAME:=Huawei HG553
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HW553/Description
+       Package set optimized for Huawei HG553 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,HW553))
+
+define Profile/HW556
+  NAME:=Huawei HG556a
+  PACKAGES:=kmod-rt2800-pci kmod-ath9k wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HW556/Description
+       Package set optimized for Huawei HG556a using open-source atheros or ralink WiFi driver
+endef
+$(eval $(call Profile,HW556))
diff --git a/target/linux/brcm63xx/profiles/202-Sagemcom.mk b/target/linux/brcm63xx/profiles/202-Sagemcom.mk
new file mode 100644 (file)
index 0000000..ebe1755
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Sagemcom-2704V2
+  NAME:=Sagemcom F@ST 2704 V2
+  PACKAGES:=kmod-b43 wpad-mini \
+    kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev 
+endef
+define Profile/Sagemcom-2704V2/Description
+  Package set optimized for Sagemcom F@ST 2704 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,Sagemcom-2704V2))
diff --git a/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk b/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk
deleted file mode 100644 (file)
index bc68f14..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom
-  NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-b43 wpad-mini
-endef
-
-define Profile/Broadcom/Description
-       Package set compatible with hardware using Broadcom WiFi cards
-endef
-$(eval $(call Profile,Broadcom))
-
diff --git a/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk b/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk
deleted file mode 100644 (file)
index 4f2d605..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-wl
-  NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
-  PACKAGES:= kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-wl/Description
-       Package set compatible with hardware using Broadcom BCM43xx cards
-       using the proprietary broadcom wireless "wl" driver.
-endef
-
-$(eval $(call Profile,Broadcom-wl))
-
diff --git a/target/linux/brcm63xx/smp/profiles/102-Atheros.mk b/target/linux/brcm63xx/smp/profiles/102-Atheros.mk
deleted file mode 100644 (file)
index b214185..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Atheros
-  NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-ath5k kmod-ath9k wpad-mini
-endef
-
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
diff --git a/target/linux/brcm63xx/smp/profiles/103-Ralink.mk b/target/linux/brcm63xx/smp/profiles/103-Ralink.mk
deleted file mode 100644 (file)
index 412c5a4..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ralink
-  NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt61-pci wpad-mini
-endef
-$(eval $(call Profile,Ralink))
-
diff --git a/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk b/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk
deleted file mode 100644 (file)
index 0f5ec37..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NoWiFi
-  NAME:=No WiFi
-  PACKAGES:=
-endef
-
-define Profile/NoWiFi/description
-  Package set compatible with BCM63xx routers without Wi-Fi.
-endef
-
-$(eval $(call Profile,NoWiFi))
diff --git a/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk b/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk
deleted file mode 100644 (file)
index bb558d1..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-brcmsmac
-  NAME:=Broadcom WiFi (brcmsmac)
-  PACKAGES:=kmod-brcmsmac wpad-mini
-endef
-
-define Profile/Broadcom-brcmsmac/Description
-       Package set compatible with hardware using Broadcom WiFi cards
-endef
-$(eval $(call Profile,Broadcom-brcmsmac))
-