Zynq: Add Zedboard device support
authorJohn Crispin <john@openwrt.org>
Tue, 26 Apr 2016 11:44:26 +0000 (11:44 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 26 Apr 2016 11:44:26 +0000 (11:44 +0000)
Tested-by: Joe Zhang <jz21082@gmail.com>
Signed-off-by: Jason Wu <jason.wu.misc@gmail.com>
SVN-Revision: 49256

package/boot/uboot-zynq/Makefile
target/linux/zynq/base-files/etc/board.d/02_network
target/linux/zynq/image/Makefile
target/linux/zynq/profiles/zed.mk [new file with mode: 0644]

index 3a17f7fcd2cee6a0f04d79e5555fecdf35dcc13d..2053e8dc0791f65f98f94a6c6a71691f813071c6 100644 (file)
@@ -37,8 +37,13 @@ define uboot/zc706
        TITLE:=U-Boot $(PKG_VERSION) for Xilinx ZC706 Dev Board
 endef
 
+define uboot/zed
+       TITLE:=U-Boot $(PKG_VERSION) for Avnet Digilent ZedBoard Dev Board
+endef
+
 UBOOTS := \
        zc702 \
+       zed \
 
 define Package/uboot/template
 define Package/uboot-zynq-$(1)
index 71d6fd8aa2e0d038d322482a3c96b1773511b3ff..35667c061084d746ffe99e78ffb43b8401c1e090 100755 (executable)
@@ -6,7 +6,7 @@
 board_config_update
 
 case "$(cat /tmp/sysinfo/board_name)" in
-       xlnx,zynq-zc702)
+       xlnx,zynq-zc702|xlnx,zynq-zed)
                ucidef_set_interface_lan 'eth0'
                ;;
 esac
index 99293a6aad4329c3f3d6f60547d10109db0615f9..87975be6a0da99fbf3e9ccdb97b588cd6e2a42ff 100644 (file)
@@ -70,6 +70,9 @@ define Device/ZC702
        $(call Device/DefaultConfig,zc702)
 endef
 
+define Device/ZED
+       $(call Device/DefaultConfig,zed)
+endef
 
 define Image/BuildKernel
        $(eval $(call Device/$(PROFILE)))
diff --git a/target/linux/zynq/profiles/zed.mk b/target/linux/zynq/profiles/zed.mk
new file mode 100644 (file)
index 0000000..d8ff08b
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZED
+       NAME:=ZedBoard development baord
+endef
+
+define Profile/ZED/Description
+       Build firmware image for Avnet Digilent ZedBoard development board.
+endef
+
+$(eval $(call Profile,ZED))