adapt profiles for subtarget changes
authorFelix Fietkau <nbd@openwrt.org>
Sat, 8 Sep 2007 20:04:43 +0000 (20:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 8 Sep 2007 20:04:43 +0000 (20:04 +0000)
SVN-Revision: 8695

21 files changed:
include/target.mk
target/linux/amazon/Makefile
target/linux/amcc/Makefile
target/linux/ar7/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm-2.4/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/etrax/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/pxa/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index 42f484af9d8d32f101572a29f1c0cc6b57eec638..8f072d0cd86de99bbc6bdca509a82d7fd6329cbd 100644 (file)
@@ -70,13 +70,17 @@ define Profile
        getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
        echo;
-  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(2),$(2)_)$(1))),y)
+  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
     PROFILE=$(1)
   endif
 endef
 
-$(eval $(call shexport,Target/Description))
+-include $(PLATFORM_DIR)/profiles/*.mk
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+  -include $(PLATFORM_SUBDIR)/profiles/*.mk
+endif
 
+$(eval $(call shexport,Target/Description))
 
 include $(INCLUDE_DIR)/kernel-version.mk
 
index 17f9d964941a61b971b776e82a556763a9f0763c..b8491c2fd2cb151ebac9942c1533476af62ac175 100644 (file)
@@ -20,7 +20,4 @@ endef
 
 KERNELNAME:="uImage"
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index a35783be4197be79a82547a377fb98b2c41f2ffe..d582d8191531f6b24d956e7eb1b49f4863558263 100644 (file)
@@ -19,7 +19,4 @@ define Target/Description
        Build firmware images for the AMCC Taishan evaluation board
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 772222ac757046d28759cf3b2e148ffb4b456de6..a355356dd0fa905c106637c2c44fb23e5d021716 100644 (file)
@@ -19,6 +19,4 @@ define Target/Description
        Build firmware images for TI AR7 based routers
 endef
 
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 7a9a1adcc34bf9ed5a94aebe41c1284952f2b399..dfa3bfbb65417605c60e9ca3958c0ffe36493fe4 100644 (file)
@@ -22,7 +22,4 @@ define Target/Description
   Build fimware images for Figment Design Labs VersaLink board.
 endef
 
-#include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index fc48efd5ded8b297f2cfa502209c3a3fce850b9d..b1a2f570aea29ba05cb460f930508225f024c49c 100644 (file)
@@ -21,7 +21,4 @@ define Target/Description
        Build firmware images for Atheros SoC boards
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index f7dcb03ed6a2586fca19af9c6f058ea8bcf7f7af..278e617b1d7140ac87405da39da5c8a660de2814 100644 (file)
@@ -27,8 +27,5 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
 
index 01d5838fe4d8adcb4c9023dd857bd225e5bb9112..5c7c0bca3c90cea51f0c0be22199bdaed5344168 100644 (file)
@@ -18,7 +18,4 @@ define Target/Description
   Build firmware images for ATNGW100 board
 endef
 
-#include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index da5cf6404f3718498fee8e33945900d41abac3ed..d93e0b6b9b84a83b570584df917ced4df8834dc6 100644 (file)
@@ -22,7 +22,4 @@ define Target/Description
        (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 5804ee9768c343beb9f4e800a9b25dff95914a47..b00d5d7401b96cd6d145ce9c64f43bf178d18cd5 100644 (file)
@@ -21,7 +21,4 @@ define Target/Description
        (e.g. Netgear WGT634U)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 93670c6eed5bf3d919889144d5bb6ddf25413381..0e0898461763cc92ad9f34911c89bfcb0552f3e3 100644 (file)
@@ -19,7 +19,4 @@ define Target/Description
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index c837550062414a9cb0c45e66bbab5e1d2cc0a4be..e644c652b5903740b51195667071210a0a2942cd 100644 (file)
@@ -34,9 +34,6 @@ define Kernel/Prepare
        $(call Kernel/Prepare/Fox)
 endef
 
-#include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
 $(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
        Please install the binary cris toolchain. \
index c097955f3433de1427100f978d8a12cbb7d3281b..df84078a3b6e4eb832fe3a66bbb886eb098746e8 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.5
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index f68f62bc7de98353f331198d74f6ffee4002a416..6e945aba2c5c59122b326cf2cd9a05e4dc428b7d 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.6
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index a20158b5221628980b07d8ce6b09ac4bc5fecc60..b13009562439d7491ba40f68e72d041205e27b60 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.22.4
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index ad44af27e47dad02aa91c00f55306a21f7225496..b5985ea74d1dad1d782be7262bc6bd64b7a749ef 100644 (file)
@@ -19,7 +19,4 @@ define Target/Description
        Stub for boards based on intel PXA
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 608f0aca148de186817d98abacf940763f818bb4..c80449dc0ffa24ec17280c5ffaa84c1f4e76c3d9 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.22.4
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index ac49adeb97482b715a7600b94a1ddf9d268d2712..961df474c1964dfc59a045d675fe61511ee987a8 100644 (file)
@@ -32,7 +32,4 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   endef
 endif
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index aa8acea1ce470ef382929351bf73f90bd3b952de..52728da1906ae71ef2e51b28161a85e17a454471 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.5
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index e31ef02bb73b6dc28fb80a7922de3841f8dd5cb1..bed9bc99ebbd5a24efcdc946a5dde7dd6eef7a10 100644 (file)
@@ -27,9 +27,6 @@ LINUX_VERSION:=2.6.22.4
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 endif
 
 $(eval $(call BuildTarget))
index 771fd191f9b001457ec545bc4dabcf51cc60c89f..d1e459ce818df515a4f3108780493842d6a27933 100644 (file)
@@ -16,8 +16,5 @@ LINUX_VERSION:=2.6.22.4
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))