restore accidentally deleted ofc patches
authorGabor Juhos <juhosg@openwrt.org>
Wed, 19 Nov 2008 20:32:13 +0000 (20:32 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 19 Nov 2008 20:32:13 +0000 (20:32 +0000)
SVN-Revision: 13293

target/linux/generic-2.6/patches-2.6.26/970-ocf_kbuild_integration.patch [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.27/970-ocf_kbuild_integration.patch [new file with mode: 0644]

diff --git a/target/linux/generic-2.6/patches-2.6.26/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.26/970-ocf_kbuild_integration.patch
new file mode 100644 (file)
index 0000000..3057307
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -675,6 +675,8 @@ config CRYPTO_PRNG
+         for cryptographic modules.  Uses the Algorithm specified in
+         ANSI X9.31 A.2.4
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -73,6 +73,11 @@ obj-$(CONFIG_CRYPTO_PRNG) += prng.o
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o
diff --git a/target/linux/generic-2.6/patches-2.6.27/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.27/970-ocf_kbuild_integration.patch
new file mode 100644 (file)
index 0000000..243708f
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -666,6 +666,8 @@ config CRYPTO_LZO
+       help
+         This is the LZO algorithm.
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -73,6 +73,11 @@ obj-$(CONFIG_CRYPTO_LZO) += lzo.o
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o