ramips: fix support Planex MZK-750DHP.
authorJohn Crispin <john@openwrt.org>
Wed, 20 Apr 2016 17:19:05 +0000 (17:19 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 20 Apr 2016 17:19:05 +0000 (17:19 +0000)
fix script for Planex MZK-750DHP.
modification of the GPIO definition.
add Profile.

Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com>
SVN-Revision: 49205

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/MZK-750DHP.dts
target/linux/ramips/mt7620/profiles/planex.mk [new file with mode: 0644]

index 5816e60f662bab1dff22eabd69274d73d1cdae94..2f40955d11047382d52a47376a5502c5b00f6279 100755 (executable)
@@ -122,6 +122,7 @@ dir-620-d1)
        set_wifi_led "$board:green:wifi"
        ;;
 dir-810l|\
+mzk-750dhp|\
 mzk-dp150n)
        ucidef_set_led_default "power" "power" "$board:green:power" "1"
        ;;
index daa7fb1afd08e992d73150311dc0f65a399126b1..a2c965d79dc59ebe1f1c079862a3cf49d0acfda6 100644 (file)
@@ -21,6 +21,7 @@ get_status_led() {
        br-6475nd|\
        e1700|\
        fonera20n|\
+       mzk-750dhp|\
        mzk-dp150n|\
        mzk-w300nh2|\
        nbg-419n|\
index c329dce4f77f9088eeab74bde145da5dcdd310ba..cbeda7accbb36e3cf202f903771982777b5c0652 100755 (executable)
@@ -86,6 +86,7 @@ platform_check_image() {
        mpr-a2|\
        mr-102n|\
        mt7628|\
+       mzk-750dhp|\
        mzk-dp150n|\
        mzk-w300nh2|\
        mzk-wdpr|\
index df0b73be9506741f1456a4f2fa2e84a40d4ff29f..5947a54022ad78202704bdb999ec7c68f2c2f4b8 100644 (file)
                        status = "okay";
                };
 
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
                spi@b00 {
                        status = "okay";
 
@@ -51,7 +55,7 @@
        pinctrl {
                state_default: pinctrl0 {
                        gpio {
-                               ralink,group = "i2c", "spi refclk", "rgmii1";
+                               ralink,group = "i2c", "spi refclk", "rgmii1", "nd_sd";
                                ralink,function = "gpio";
                        };
                };
 
        pcie@10140000 {
                status = "okay";
+
+               pcie-bridge {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8000>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
        };
        
        gpio-leds {
 
                wps {
                        label = "mzk-750dhp:green:wps";
-                       gpios = <&gpio1 11 1>;
+                       gpios = <&gpio2 15 1>;
                };
 
                power {
                        label = "mzk-750dhp:green:power";
                        gpios = <&gpio1 15 1>;
                };
+
+               wlan5g {
+                       label = "mzk-750dhp:green:wlan5g";
+                       gpios = <&gpio1 14 1>;
+               };
        };
 
        gpio-keys-polled {
                s1 {
                        label = "reset";
                        gpios = <&gpio0 1 1>;
-                       linux,code = <0x100>;
+                       linux,code = <0x198>;
                };
 
                s2 {
                        label = "wps";
-                       gpios = <&gpio0 2 1>;
+                       gpios = <&gpio2 19 1>;
                        linux,code = <0x211>;
                };
        };
diff --git a/target/linux/ramips/mt7620/profiles/planex.mk b/target/linux/ramips/mt7620/profiles/planex.mk
new file mode 100644 (file)
index 0000000..f6f2cf1
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MZK-750DHP
+       NAME:=Planex MZK-750DHP
+       PACKAGES:= kmod-mt76 kmod-mt7610e
+endef
+
+define Profile/MZK-750DHP/Description
+       Package set optimized for the Planex MZK-750DHP.
+endef
+$(eval $(call Profile,MZK-750DHP))