apm821xx: Merge the Cisco Meraki MX60 & MX60W
authorChris Blake <chrisrblake93@gmail.com>
Fri, 31 Mar 2017 09:32:55 +0000 (04:32 -0500)
committerFelix Fietkau <nbd@nbd.name>
Wed, 26 Apr 2017 09:34:17 +0000 (11:34 +0200)
Both of these boards share the same DTS, and hardware. The only
difference would be the PCI-E slot, and ath9k card found on the MX60W.
Due to the similarities, it would be more efficient to merge these
profiles.

Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
target/linux/apm821xx/image/Makefile

index 1dae2b6636aa005848979e9c5ebbef805216c607..6ed183c3767c1ec849b47882b8c5c9b65ae58703 100644 (file)
@@ -88,7 +88,7 @@ endef
 TARGET_DEVICES += mr24
 
 define Device/mx60
-  DEVICE_TITLE := Cisco Meraki MX60
+  DEVICE_TITLE := Cisco Meraki MX60/MX60W
   DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
   kmod-usb-storage block-mount
   DEVICE_PROFILE := MX60
@@ -112,12 +112,6 @@ define Device/mx60
 endef
 TARGET_DEVICES += mx60
 
-define Device/mx60w
-$(Device/mx60)
-  DEVICE_TITLE := Cisco Meraki MX60W
-endef
-TARGET_DEVICES += mx60w
-
 define Build/create-uImage-dtb
        # flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
        -$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \