speed up the prepare step a bit
authorFelix Fietkau <nbd@openwrt.org>
Mon, 30 Jul 2007 21:47:26 +0000 (21:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 30 Jul 2007 21:47:26 +0000 (21:47 +0000)
SVN-Revision: 8245

include/package.mk

index c68bd1065201f9e78f071059cedf28a6b0ed0050..cccf17437ec48edc7e1365b992c598d492aef111 100644 (file)
@@ -32,7 +32,7 @@ ifeq ($(DUMP)$(filter prereq clean refresh update,$(MAKECMDGOALS)),)
     define Build/Autoclean
       $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
       $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
-      $(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
+      $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
     endef
   endif
 endif