fixed autoconf detection for 2.6.33 kernel
authorRalph Hempel <ralph.hempel@lantiq.com>
Sun, 25 Apr 2010 15:57:07 +0000 (15:57 +0000)
committerRalph Hempel <ralph.hempel@lantiq.com>
Sun, 25 Apr 2010 15:57:07 +0000 (15:57 +0000)
SVN-Revision: 21157

package/ifxos/patches/100-portability.patch

index 51d6bbd165beb51f8aae2a56f3396756a0ecefa3..bda6f253e2302b184948dff45b4039d146271d42 100644 (file)
@@ -1,8 +1,6 @@
-Index: lib_ifxos-1.5.12/src/Makefile.am
-===================================================================
---- lib_ifxos-1.5.12.orig/src/Makefile.am      2010-01-08 18:12:15.000000000 +0100
-+++ lib_ifxos-1.5.12/src/Makefile.am   2010-03-31 18:56:12.000000000 +0200
-@@ -639,7 +639,7 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -639,7 +639,7 @@ if KERNEL_2_6
  drv_ifxos_OBJS = "$(subst .c,.o,$(filter %.c,$(drv_ifxos_SOURCES)))"
  
  drv_ifxos.ko: $(drv_ifxos_SOURCES)
@@ -11,7 +9,7 @@ Index: lib_ifxos-1.5.12/src/Makefile.am
        if test ! -e common/ifxos_debug.c ; then \
                echo "copy source files (as links only!)"; \
                for f in $(filter %.c,$(drv_ifxos_SOURCES)); do \
-@@ -647,10 +647,10 @@
+@@ -647,10 +647,10 @@ drv_ifxos.ko: $(drv_ifxos_SOURCES)
                        cp -s $(addprefix @abs_srcdir@/,$$f) $(PWD)/`dirname $$f`/ ; \
                done \
        fi
@@ -26,3 +24,14 @@ Index: lib_ifxos-1.5.12/src/Makefile.am
        $(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
  
  clean-generic:
+--- a/configure.in
++++ b/configure.in
+@@ -64,7 +64,7 @@ dnl Set kernel build path
+ AC_ARG_ENABLE(kernelbuild,
+       AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path (only for kernel 2.6.x)),
+       [
+-              if test -e $enableval/include/linux/autoconf.h; then
++              if test -e $enableval/include/{linux,generated}/autoconf.h; then
+                       AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
+               else
+                       AC_MSG_ERROR([The kernel build directory is not valid or not configured!])