remove hacks to disable modules on some targets now that we do have proper PCI &...
authorNicolas Thill <nico@openwrt.org>
Mon, 26 May 2008 22:57:51 +0000 (22:57 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 26 May 2008 22:57:51 +0000 (22:57 +0000)
SVN-Revision: 11272

package/acx-mac80211/Makefile
package/acx/Makefile
package/kernel/modules/other.mk
package/kernel/modules/sound.mk
package/kernel/modules/video.mk
package/mac80211/Makefile
package/nw802-2.4/Makefile
package/ov51x-jpeg/Makefile
package/p54/Makefile
package/rt2500/Makefile

index 4c96cdf4ab2bb7c6380a9a533b45028bedbe8e5a..d2b6d8adb0e839fce983f398847f7da9b7c6ab7f 100644 (file)
@@ -27,11 +27,10 @@ PKG_FW_C19_MD5SUM:=a1fa9681e297b4e36e257090fc12265a
 
 include $(INCLUDE_DIR)/package.mk
 
-# XXX: remove @!TARGET_* later when we have PCI support properly detected on all targets
 define KernelPackage/acx-mac80211
   SUBMENU:=Wireless Drivers
   TITLE:=ACX111 Mac80211 driver
-  DEPENDS:=+kmod-mac80211 @!TARGET_atheros @!TARGET_uml @BROKEN
+  DEPENDS:=@LINUX_2_6 @PCI_SUPPORT||TARGET_ar7 +kmod-mac80211 @BROKEN
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
 endef
index 107a54f8feae9470889ae0f6b7c8c2b3974716e9..c1dbe3530995be07a076b47bffdde2df520aed9b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -32,10 +32,9 @@ PKG_UNPACK:= \
 
 include $(INCLUDE_DIR)/package.mk
 
-# XXX: remove @!TARGET_* later when we have PCI support properly detected on all targets
 define KernelPackage/acx
   TITLE:=Driver for TI ACX1xx chipset
-  DEPENDS:=@LINUX_2_6 +wireless-tools @!TARGET_atheros @!TARGET_avr32 @!TARGET_uml
+  DEPENDS:=@LINUX_2_6 @CONFIG_PCI||TARGET_ar7 +wireless-tools
   URL:=http://acx100.sourceforge.net/
   SUBMENU:=Wireless Drivers
   FILES:= $(PKG_BUILD_DIR)/acx.$(LINUX_KMOD_SUFFIX)
index d7d078d370615641831039ea935256abe8e31650..a096552bdd14099fdf44aa87b1eda0ded9182f14 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -154,11 +154,10 @@ endef
 $(eval $(call KernelPackage,pcmcia-serial))
 
 
-# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT @!TARGET_uml
+  DEPENDS:=@USB_SUPPORT
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \
@@ -306,7 +305,6 @@ endef
 $(eval $(call KernelPackage,softdog))
 
 
-# XXX: remove @TARGET_* later when we are able to detect the exact version of the kernel
 define KernelPackage/leds-gpio
   SUBMENU:=$(OTHER_MENU)
   TITLE:=GPIO LED support
index a6978070169f2cd531cd882295af550caeb187b7..547fddc8305fab3bfc86b42736081a655577d51b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,10 @@
 
 SOUND_MENU:=Sound Support
 
-# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@USB_SUPPORT||PCI_SUPPORT
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
index bd950e34365a0344e3c7d1b7bb2eb10386233949..da19de65712733f3a0f21de5db56733a2dc706c9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ VIDEO_MENU:=Video Support
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
-  DEPENDS:= @!TARGET_uml
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
   KCONFIG:= \
        CONFIG_VIDEO_DEV \
        CONFIG_VIDEO_V4L1=y \
index cd4f936546dd4fa9642bfeb2d7d0b54a277ef7bf..bbcba63fce70922816337331c6e046bab822891b 100644 (file)
@@ -19,12 +19,10 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
-# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
-
 define KernelPackage/mac80211
   SUBMENU:=Wireless Drivers
   TITLE:=Linux 802.11 Wireless Networking Stack
-  DEPENDS:=@LINUX_2_6_23||LINUX_2_6_24 +kmod-crypto-arc4 +kmod-crypto-aes +wireless-tools
+  DEPENDS:=@LINUX_2_6_23||LINUX_2_6_24||LINUX_2_6_25 +kmod-crypto-arc4 +kmod-crypto-aes +wireless-tools
   FILES:= \
        $(PKG_BUILD_DIR)/net/mac80211/mac80211.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/net/wireless/cfg80211.$(LINUX_KMOD_SUFFIX)
@@ -56,7 +54,7 @@ $(eval $(call Download,rt71w))
 define KernelPackage/rt2x00/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Ralink Drivers for RT2x00 cards
-  DEPENDS:=@LINUX_2_6_24 @!TARGET_ar7 @!TARGET_atheros @!TARGET_uml
+  DEPENDS:=@LINUX_2_6_24||LINUX_2_6_25
 endef
 
 define KernelPackage/rt2x00-lib
index f9c2ad4ef988f37d0bb69fd0fe8697f2dac5986f..ff39ad7720f61828cc4538bc2e114e7686efda6a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -19,12 +19,11 @@ PKG_MD5SUM:=bf3512efaa48cfa972b16318011c1963
 
 include $(INCLUDE_DIR)/package.mk
 
-# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
 define KernelPackage/video-nw8xx
   SUBMENU:=Video Support
   TITLE:=NW8xx based USB webcam support
   URL:=http://nw802.sourceforge.net/
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-video kmod-video-core @!TARGET_atheros @!TARGET_uml
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-video kmod-video-core
   FILES:=$(PKG_BUILD_DIR)/nw8xx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,70,nw8xx)
 endef
index 4ef1bd281307c03a30609c4320346099816c7566..7bd06d9d66db58a9534bd239d27fb6074634f163 100644 (file)
@@ -36,12 +36,11 @@ define Package/ov51x-jpeg-utils/description
  Utility programs for the video-ov51x kernel module
 endef
 
-# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
 define KernelPackage/video-ov51x-jpeg
 $(call Package/ov51x-jpeg/Default)
   SUBMENU:=Video Support
   TITLE:=OV51x based USB webcam support (JPEG)
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core @!TARGET_atheros @!TARGET_uml
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
   FILES:=$(PKG_BUILD_DIR)/ov51x-jpeg.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,70,ov51x-jpeg)
 endef
index df2e40433be14c66b14cdd8faf9ffc4a0c9eda06..65e8f232f5ce6a443aa9d58d50691b129459249d 100644 (file)
@@ -18,12 +18,10 @@ PKG_FWP54_MD5SUM:=09f9da7ea757173c9de1a0322a1f9782
 
 include $(INCLUDE_DIR)/package.mk
 
-# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
-
 define KernelPackage/p54/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Prism Wireless Support (mac80211)
-  DEPENDS:=+kmod-mac80211 @!TARGET_ar7 @!TARGET_atheros @!TARGET_uml
+  DEPENDS:=+kmod-mac80211 @BROKEN
 endef
 
 define KernelPackage/p54-common
index 76d92ca170403545e1f3068b7af943ec37794c46..0b3e0136a78b10452dfcaa4d0b311619cb75bc51 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/rt2500
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for Ralink RT2500 pci wireless chipsets
-  DEPENDS:=@!LINUX_2_6_24 @!BIG_ENDIAN @USB_SUPPORT +wireless-tools
+  DEPENDS:=@!LINUX_2_6_24&&!LINUX_2_6_25 @!BIG_ENDIAN @USB_SUPPORT +wireless-tools
   URL:=http://rt2x00.serialmonkey.com/
   FILES:=$(PKG_BUILD_DIR)/Module/rt2500.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,rt2500)