get rid of a shell warning if md5sum is not found
authorFelix Fietkau <nbd@openwrt.org>
Tue, 2 Sep 2008 10:57:56 +0000 (10:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 2 Sep 2008 10:57:56 +0000 (10:57 +0000)
SVN-Revision: 12494

include/scan.mk

index 19350b612bbf39b2bc5e403fd02536fb67ed92ed..7b818e8aba3c2282c86eb4bda9b432cb39a14e04 100644 (file)
@@ -52,7 +52,7 @@ $(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
 $(TARGET_STAMP)::
        +( \
                $(NO_TRACE_MAKE) $(FILELIST); \
-               MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) | awk '{print $$1}'); \
+               MD5SUM=$$(cat $(FILELIST) | (md5sum || md5) 2>/dev/null | awk '{print $$1}'); \
                [ -f "$@.$$MD5SUM" ] || { \
                        rm -f $@.*; \
                        touch $@.$$MD5SUM; \