Add a cellvision profile for ADM5120 IP based cameras, build several modules for...
authorFlorian Fainelli <florian@openwrt.org>
Mon, 11 Jun 2007 21:35:12 +0000 (21:35 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 11 Jun 2007 21:35:12 +0000 (21:35 +0000)
SVN-Revision: 7575

package/kernel/modules/usb.mk
target/linux/adm5120-2.6/config/default
target/linux/adm5120-2.6/profiles/Cellvision.mk [new file with mode: 0644]

index ee783c8a6022ae9d63a377183bcef5e41d8985d9..3094dbeabc2a8ffe5f59da3b84d1a1e28f2e21eb 100644 (file)
@@ -304,6 +304,23 @@ define KernelPackage/usb-pwc/2.6
 endef
 $(eval $(call KernelPackage,usb-pwc))
 
+define KernelPackage/cpia2
+  $(call usbdep,+kmod-videodev)
+  TITLE:=CPIA2 video driver
+  DESCRIPTION:=Kernel modules for CPIA2 WebCam devices
+  KCONFIG:=$(CONFIG_VIDEO_CPIA2)
+  AUTOLOAD:=$(call AutoLoad,70,cpia2)
+endef
+
+define KernelPackage/cpia2/2.4
+  FILES:=$(LINUX_DIR)/drivers/usb/cpia2.$(LINUX_KMOD_SUFFIX)
+endef
+
+define KernelPackage/cpia2/2.6
+  FILES:=$(LINUX_DIR)/drivers/media/video/cpia2/cpia2.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,cpia2))
+
 define KernelPackage/usb-net
   $(call usbdep,)
   TITLE:=Kernel modules for USB-to-Ethernet convertors
index d83efc2baf063f7cede7bdb804bde4cfe34cc195..4aeffadb2b87b0297c6e1461a88c56095f8c1782 100644 (file)
@@ -234,7 +234,6 @@ CONFIG_SERIO_SERPORT=y
 # CONFIG_SIBYTE_RHONE is not set
 # CONFIG_SIBYTE_SENTOSA is not set
 # CONFIG_SIBYTE_SWARM is not set
-# CONFIG_SND_USB_AUDIO is not set
 CONFIG_SOFT_WATCHDOG=m
 # CONFIG_SPARSEMEM_STATIC is not set
 CONFIG_SYSVIPC_SYSCTL=y
@@ -253,21 +252,32 @@ CONFIG_USB=y
 # CONFIG_USBPCWATCHDOG is not set
 # CONFIG_USB_ACM is not set
 CONFIG_USB_ADM5120_HCD=y
-# CONFIG_USB_ATM is not set
 # CONFIG_USB_CATC is not set
-# CONFIG_USB_DEVICEFS is not set
 # CONFIG_USB_EHCI_HCD is not set
+# CONFIG_USB_ET61X251 is not set
 # CONFIG_USB_GTCO is not set
+# CONFIG_USB_IBMCAM is not set
 # CONFIG_USB_KAWETH is not set
+# CONFIG_USB_KONICAWC is not set
+# CONFIG_USB_OV511 is not set
 # CONFIG_USB_PEGASUS is not set
-# CONFIG_USB_PRINTER is not set
+# CONFIG_USB_PWC is not set
+# CONFIG_USB_QUICKCAM_MESSENGER is not set
 # CONFIG_USB_RTL8150 is not set
+# CONFIG_USB_SE401 is not set
 # CONFIG_USB_SERIAL is not set
-# CONFIG_USB_STORAGE is not set
+# CONFIG_USB_SN9C102 is not set
+# CONFIG_USB_STV680 is not set
 # CONFIG_USB_UHCI_HCD is not set
 # CONFIG_USB_USBNET is not set
 # CONFIG_USB_USBNET_MII is not set
+# CONFIG_USB_VICAM is not set
+# CONFIG_USB_ZC0301 is not set
 # CONFIG_USB_ZD1201 is not set
+# CONFIG_VIDEO_CPIA is not set
+CONFIG_VIDEO_CPIA2=m
+# CONFIG_VIDEO_STRADIS is not set
+CONFIG_VIDEO_V4L1=y
 CONFIG_VM_EVENT_COUNTERS=y
 CONFIG_YAFFS_9BYTE_TAGS=y
 # CONFIG_YAFFS_ALWAYS_CHECK_CHUNK_ERASED is not set
diff --git a/target/linux/adm5120-2.6/profiles/Cellvision.mk b/target/linux/adm5120-2.6/profiles/Cellvision.mk
new file mode 100644 (file)
index 0000000..6599647
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Cellvision
+  NAME:=Cellvision CAS-63x/77x cameras
+  PACKAGES:=kmod-rt2500 kmod-cpia2 kmod-usb-audio
+endef
+
+define Profile/Cellvision/Description
+  Package set compatible with the Cellvision CAS devices.
+endef
+$(eval $(call Profile,Cellvision))