grub2: add PKG_FIXUP:=autoreconf
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 17 Nov 2016 16:25:52 +0000 (18:25 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 20 Dec 2016 15:24:21 +0000 (16:24 +0100)
Reboot of: a0ea22ac430f91ab045431a79b2e2161e66cd56a
Reverted: 3c52cbfa53056ded95ae5a7ae27319eafd5a37e5

The host-side build of grub2 requires this sometimes.
This will re-generate the ./configure script from configure.ac.
I don't know the conditions of how this reproduces, it just
sometimes appears, and sometimes doesn't.

Build error
```
<lede-dir>/build_dir/target-x86_64_musl-1.1.15_yogi/host/grub-2.02~beta2/build-aux/missing: line 81: aclocal-1.14: command not found
WARNING: 'aclocal-1.14' is missing on your system.
         You should only need it if you modified 'acinclude.m4' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'aclocal' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
Makefile:3962: recipe for target 'aclocal.m4' failed
```

Adding PKG_FIXUP adds sanity (i.e. autoreconf is used for host & target
builds) over just using HOST_FIXUP.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
package/boot/grub2/Makefile

index 75f5e826c1828ea8209c649a98adf9cccf631840..6b96e0a8d1910f1177506b89b34459c75177b7a1 100644 (file)
@@ -19,6 +19,7 @@ PKG_SOURCE_URL:=http://alpha.gnu.org/gnu/grub \
        http://www.nic.funet.fi/pub/gnu/alpha/gnu/grub/
 PKG_HASH:=f6c702b2a8ea58f27a2b02928bb77973cb5a827af08f63db38c471c0a01b418d
 
+PKG_FIXUP:=autoreconf
 HOST_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=grub2/host