add preliminary support for the Planex MZK-W300NH board
authorGabor Juhos <juhosg@openwrt.org>
Sun, 4 Jan 2009 19:46:41 +0000 (19:46 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 4 Jan 2009 19:46:41 +0000 (19:46 +0000)
SVN-Revision: 13863

target/linux/ar71xx/config-2.6.26
target/linux/ar71xx/config-2.6.27
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h

index 518f2975f3940ae9f4ee8154c5b731e4716749a0..a006dd998e5d2da64136b7ae7c1d05cb486b0868 100644 (file)
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
index 502f458ed64e225acf2d3225dcd91820ed08ebc8..337efdd10b32309bfbb86dd2cfc0678e55dd7cf9 100644 (file)
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
index 522f1c7e154b553ffa0f3b84e91ccb6c4425d312..7b69cad7385310cfef88dd46eade196bc7e6e864 100644 (file)
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
index 09ffdfe07f73973eb414165fdb1357bb481af348..64f19bf62c72eabddfc95b8151ec7f5a1ee6d24b 100644 (file)
@@ -121,7 +121,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_UBNT_LSX   10      /* Ubiquiti LSX */
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
 #define AR71XX_MACH_PB42       12      /* Atheros PB42 */
-
+#define AR71XX_MACH_MZK_W300NH 13      /* Planex MZK-W300NH */
 
 /*
  * PLL block
index d8e22470f40b71b474ad67b01da39c32c2c80404..cd2624cc66b48419b0e6b01493313de01f122255 100644 (file)
@@ -35,6 +35,10 @@ config AR71XX_MACH_WNR2000
        bool "NETGEAR WNR2000 board support"
        default y
 
+config AR71XX_MACH_MZK_W300NH
+       bool "Planex MZK-W300NH board support"
+       default y
+
 config AR71XX_MACH_TEW_632BRP
        bool "TRENDnet TEW-632BRP support"
        default y
index b634e36d68833ca2c5a1d4499ce4de2fcc5733f3..33118d77410924bc624d83b8f3c0267ea14d0aaf 100644 (file)
@@ -13,6 +13,7 @@ obj-y := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
+obj-$(CONFIG_AR71XX_MACH_MZK_W300NH)   += mach-mzk-w300nh.o
 obj-$(CONFIG_AR71XX_MACH_PB42)         += mach-pb42.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c
new file mode 100644 (file)
index 0000000..2f429be
--- /dev/null
@@ -0,0 +1,80 @@
+/*
+ *  Planex MZK-W300NH board support
+ *
+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/platform.h>
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition mzk_w300nh_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x040000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "u-boot-env",
+               .offset         = 0x040000,
+               .size           = 0x010000,
+       } , {
+               .name           = "uImage",
+               .offset         = 0x050000,
+               .size           = 0x160000,
+       } , {
+               .name           = "rootfs",
+               .offset         = 0x1b0000,
+               .size           = 0x610000,
+       } , {
+               .name           = "config",
+               .offset         = 0x7c0000,
+               .size           = 0x020000,
+       } , {
+               .name           = "art",
+               .offset         = 0x7e0000,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data mzk_w300nh_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+        .parts          = mzk_w300nh_partitions,
+        .nr_parts       = ARRAY_SIZE(mzk_w300nh_partitions),
+#endif
+};
+
+static struct spi_board_info mzk_w300nh_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+               .platform_data  = &mzk_w300nh_flash_data,
+       }
+};
+
+static void __init mzk_w300nh_setup(void)
+{
+       ar71xx_add_device_spi(NULL, mzk_w300nh_spi_info,
+                                       ARRAY_SIZE(mzk_w300nh_spi_info));
+
+       ar91xx_add_device_wmac();
+}
+
+MIPS_MACHINE(AR71XX_MACH_MZK_W300NH, "Planex MZK-W300NH", mzk_w300nh_setup);
index bb6a112a2373ae7a1f28e30b3e1c0b0145ca0856..d05217c615f2bb40607945008e36c2500b82f65c 100644 (file)
@@ -64,6 +64,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "PB42",
                .mach_type      = AR71XX_MACH_PB42,
+       }, {
+               .name           = "MZK-W300NH",
+               .mach_type      = AR71XX_MACH_MZK_W300NH,
        }
 };
 
index 3895b21e4cdecf749c2416347bd66f28ec74ec21..64f19bf62c72eabddfc95b8151ec7f5a1ee6d24b 100644 (file)
@@ -121,6 +121,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_UBNT_LSX   10      /* Ubiquiti LSX */
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
 #define AR71XX_MACH_PB42       12      /* Atheros PB42 */
+#define AR71XX_MACH_MZK_W300NH 13      /* Planex MZK-W300NH */
 
 /*
  * PLL block