made au1000 images srec file ending
authorJohn Crispin <john@openwrt.org>
Thu, 20 Dec 2007 22:12:56 +0000 (22:12 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 20 Dec 2007 22:12:56 +0000 (22:12 +0000)
SVN-Revision: 9811

target/linux/au1000/image/Makefile

index 062d61314408d66372c1e2570882ec2d846f2e76..3a672d9e880e6be9af58da47e66395c68669a5cc 100644 (file)
@@ -56,8 +56,8 @@ endef
 
 define Image/Build
        $(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma $(FLASH_FS) $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec
-       grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
-       grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+       grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/openwrt-$(BOARD)-$(1).srec
+       grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(1).srec
        $(INSTALL_BIN) $(KDIR)/kernel.flash.bin $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.bin
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
        $(CP) $(KDIR)/kernel.flash.srec $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-flash.srec