Fix partitions for Cameo-based boards; kernel 3.2 is bigger
authorDaniel Dickinson <crazycshore@gmail.com>
Thu, 16 Feb 2012 07:29:26 +0000 (07:29 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Thu, 16 Feb 2012 07:29:26 +0000 (07:29 +0000)
SVN-Revision: 30569

target/linux/ar71xx/image/Makefile

index 2caa58637d3b4aee3ff5149cf7ef4922d5c32492..2cde9cb6793e65431bd5a333baf1e0eb2c5e2280 100644 (file)
@@ -206,14 +206,14 @@ define Image/Build/Cameo
        fi
 endef
 
-cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,896k(kernel),2944k(rootfs),64k(art)ro,3840k@0x30000(firmware)
+cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,960k(kernel),2880k(rootfs),64k(art)ro,3840k@0x30000(firmware)
 define Image/Build/Cameo913x
-       $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),917504,2949120,$(4))
+       $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),983040,2949120,$(4))
 endef
 
-cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,896k(kernel),2816k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
+cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,960k(kernel),2752k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
 define Image/Build/Cameo7240
-       $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo7240_mtdlayout),917504,2818048,$(4))
+       $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo7240_mtdlayout),983040,2818048,$(4))
 endef
 
 define Image/Build/Ath