Some packages make no sense or do not build for etrax
authorJohn Crispin <john@openwrt.org>
Sun, 29 Jul 2007 15:50:32 +0000 (15:50 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 29 Jul 2007 15:50:32 +0000 (15:50 +0000)
SVN-Revision: 8216

package/hostapd/Makefile
package/ipset/Makefile
package/madwifi/Makefile
package/util-linux/Makefile

index 7e0f0877f68320b9449615c74de4a82ed94ad82f..86ce41457387403121b79c06caec40aef13a6db5 100644 (file)
@@ -29,7 +29,7 @@ endef
 
 define Package/hostapd
   $(call Package/hostapd/Default)
-  DEPENDS:=+libopenssl @!LINUX_2_6_AVR32
+  DEPENDS:=+libopenssl @!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
   TITLE+= (full)
   DESCRIPTION:=\
        This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS \\\
@@ -42,7 +42,7 @@ endef
 
 define Package/hostapd-mini
   $(call Package/hostapd/Default)
-  DEPENDS:=@!LINUX_2_6_AVR32
+  DEPENDS:=@!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
   TITLE+= (WPA-PSK only)
   DESCRIPTION:=\
        This package contains a minimal IEEE 802.1x/WPA/EAP/RADIUS Authenticator \\\
index bcc80840a35a223d4583cf0105175f99296f0888..62e63d36ee328ec8ebd5fe9d3cf92b1eafed48fe 100644 (file)
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ipset
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=@!LINUX_2_6_ETRAX
   TITLE:=Netfilter ip sets administration utility
   URL:=http://ipset.netfilter.org/
 endef
index 907f19117992a7eff1dedd40f7f279135d28b46f..f063af800f23a2639853339dc0fb90dd3d47988e 100644 (file)
@@ -81,7 +81,7 @@ endif
 define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for Atheros wireless chipsets
-  DEPENDS:=+wireless-tools @!LINUX_2_6_AVR32
+  DEPENDS:=+wireless-tools @!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
   DESCRIPTION:=\
        This package contains a driver for Atheros 802.11a/b/g chipsets.
   URL:=http://madwifi.org/
index f624e92ccc95ead3f01c60563f7f5d65c5a81b8b..6c5a6972f666da299a30d0009bbcd6e75d330fee 100644 (file)
@@ -30,6 +30,7 @@ endef
 define Package/fdisk
   $(call Package/util-linux/Default)
   TITLE:=Partition table manipulation utility
+  DEPENDS:=@!LINUX_2_6_ETRAX
   DESCRIPTION:=\
        This package contains a utility for managing disk partition tables.
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
@@ -38,7 +39,7 @@ endef
 define Package/cfdisk
   $(call Package/util-linux/Default)
   TITLE:=Partition table manipulation utility
-  DEPENDS:=+libncurses
+  DEPENDS:=+libncurses @!LINUX_2_6_ETRAX
   DESCRIPTION:=\
        This package contains a utility for managing disk partition tables.
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
@@ -47,6 +48,7 @@ endef
 define Package/losetup
   $(call Package/util-linux/Default)
   TITLE:=Loopback devices setup and control utility
+  DEPENDS:=@!LINUX_2_6_ETRAX
   DESCRIPTION:=\
        This package contains a utility for managing loopback devices.
 endef
@@ -54,6 +56,7 @@ endef
 define Package/swap-utils
   $(call Package/util-linux/Default)
   TITLE:=Swap space management utilities
+  DEPENDS:=@!LINUX_2_6_ETRAX
   DESCRIPTION:=\
        This package contains a collection of tools for managing swap space: \\\
        - mkswap\\\
@@ -64,6 +67,7 @@ endef
 define Package/hwclock
   $(call Package/util-linux/Default)
   TITLE:=Utilities for managing the hardware clock
+  DEPENDS:=@!LINUX_2_6_ETRAX
   DESCRIPTION:=\
         This package contains a utility for managing the hardware clock
 endef