kernel: can: Add missing regmap dependency for kernel 4.4
authorFlorian Fainelli <f.fainelli@gmail.com>
Sun, 15 Jan 2017 05:34:02 +0000 (21:34 -0800)
committerJohn Crispin <john@phrozen.org>
Sun, 15 Jan 2017 16:43:14 +0000 (17:43 +0100)
Fixes build failure for kmod-can-c-can-platform which depends on
kmod-regmap for kernel 4.1 and 4.4.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/kernel/linux/modules/can.mk

index eeef88a835ce81fd75c14de4ccce6cf108995cd5..5529fe02e0cd9f17adfd82c5f2da0b652664d892 100644 (file)
@@ -241,7 +241,7 @@ $(eval $(call KernelPackage,can-c-can))
 define KernelPackage/can-c-can-platform
   TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
   KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
-  DEPENDS:=kmod-can-c-can +LINUX_4_1:kmod-regmap
+  DEPENDS:=kmod-can-c-can +!LINUX_3_18:kmod-regmap
   FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
   AUTOLOAD:=$(call AutoProbe,c_can_platform)
   $(call AddDepends/can)