allow targets to select/deselect config symbols
authorFelix Fietkau <nbd@openwrt.org>
Fri, 5 Oct 2007 21:44:43 +0000 (21:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 5 Oct 2007 21:44:43 +0000 (21:44 +0000)
SVN-Revision: 9150

include/target.mk
scripts/metadata.pl

index 0217fcff6ff287d6a3a36303ac0a8276e6b806ef..9ee369d9b123ee31c508e8f77fc8cecb392d942d 100644 (file)
@@ -150,6 +150,7 @@ define BuildTargets/DumpCurrent
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \
+        echo 'Target-Depends: $(DEPENDS)'; \
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
index aa5df6fb9d49fbebe2e5b11a1f4eccb79778af56..580e29ea0ba02a589ff776ad3cf2241cf9284352 100755 (executable)
@@ -25,7 +25,9 @@ sub parse_target_metadata() {
                        $target = {
                                id => $1,
                                conf => confstr($1),
                        $target = {
                                id => $1,
                                conf => confstr($1),
-                               profiles => []
+                               profiles => [],
+                               features => [],
+                               depends => []
                        };
                        push @target, $target;
                };
                        };
                        push @target, $target;
                };
@@ -38,6 +40,7 @@ sub parse_target_metadata() {
                /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;
                /^Target-Features:\s*(.+)\s*$/ and $target->{features} = [ split(/\s+/, $1) ];
                /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;
                /^Target-Features:\s*(.+)\s*$/ and $target->{features} = [ split(/\s+/, $1) ];
+               /^Target-Depends:\s*(.+)\s*$/ and $target->{depends} = [ split(/\s+/, $1) ];
                /^Target-Description:/ and $target->{desc} = get_multiline(*FILE);
                /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
                /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
                /^Target-Description:/ and $target->{desc} = get_multiline(*FILE);
                /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
                /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
@@ -189,6 +192,20 @@ EOF
                if ($target->{id} ne $target->{board}) {
                        print "\tselect TARGET_".$target->{boardconf}."\n";
                }
                if ($target->{id} ne $target->{board}) {
                        print "\tselect TARGET_".$target->{boardconf}."\n";
                }
+               foreach my $dep (@{$target->{depends}}) {
+                       my $mode = "depends";
+                       my $flags;
+                       my $name;
+
+                       $dep =~ /^([@\+\-]+)(.+)$/;
+                       $flags = $1;
+                       $name = $2;
+
+                       $flags =~ /-/ and $mode = "deselect";
+                       $flags =~ /\+/ and $mode = "select";
+                       $flags =~ /@/ and print "\t$mode $name\n";
+               }
+               
                print "$features$help\n\n"
        }
 
                print "$features$help\n\n"
        }