add support for device type based package preselections
authorFelix Fietkau <nbd@openwrt.org>
Sat, 8 Sep 2007 21:30:25 +0000 (21:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 8 Sep 2007 21:30:25 +0000 (21:30 +0000)
SVN-Revision: 8696

include/kernel-defaults.mk

index 88f1c36758224d0a979ef01388cb772872d0e9f2..40316e000371334bd6d4aeaabf0ff2bfd311c611 100644 (file)
@@ -5,12 +5,22 @@
 # See /LICENSE for more information.
 #
 
-# For target profile selection - the default set
-DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd kmod-ipt-nathelper
+# default device type
+DEVICE_TYPE?=router
+
+# Default packages - the really basic set
+DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd mtd
+# For router targets
+DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe iptables kmod-ipt-nathelper bridge
+
+# Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
-  DEFAULT_PACKAGES+=udevtrigger hotplug2
+  DEFAULT_PACKAGES += udevtrigger hotplug2
 endif
 
+# Add device specific packages
+DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
+
 KERNELNAME=
 ifneq (,$(findstring x86,$(BOARD)))
   KERNELNAME="bzImage"