hostapd: use libnl-tiny instead of libnl
authorFelix Fietkau <nbd@openwrt.org>
Thu, 30 Apr 2009 18:11:01 +0000 (18:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 30 Apr 2009 18:11:01 +0000 (18:11 +0000)
SVN-Revision: 15519

package/hostapd/Makefile
package/hostapd/patches/130-libnl_update.patch [new file with mode: 0644]

index 0c1d6fc776758e3ed386324b242c30f9f18bc1db..bd873b9b2f40ee5e69927692472139d0188526ff 100644 (file)
@@ -20,7 +20,6 @@ PKG_MD5SUM:=83630d11fa66ade9091f1b304fccd74c
 PKG_BUILD_DEPENDS:= \
        PACKAGE_kmod-madwifi:madwifi \
        PACKAGE_kmod-mac80211:mac80211 \
-       PACKAGE_kmod-mac80211:libnl \
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_kmod-ath9k \
@@ -41,7 +40,7 @@ define Package/hostapd/Default
   CATEGORY:=Network
   TITLE:=IEEE 802.1x Authenticator
   URL:=http://hostap.epitest.fi/
-  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny
 endef
 
 define Package/hostapd
@@ -94,13 +93,20 @@ define Build/ConfigureTarget
        $(CP) ./files/$(1).config $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/.config
 endef
 
+TARGET_CPPFLAGS := \
+       -I$(STAGING_DIR)/usr/include/libnl-tiny \
+       $(TARGET_CPPFLAGS) \
+       -I$(STAGING_DIR)/usr/include/madwifi \
+       -I$(STAGING_DIR)/usr/include/mac80211 \
+       -DCONFIG_LIBNL20
+
 define Build/CompileTarget
-       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/madwifi -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl $(TARGET_CPPFLAGS)" \
+       CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
        $(MAKE) -C $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd \
                $(TARGET_CONFIGURE_OPTS) \
                $(DRIVER_MAKEOPTS) \
                LIBS="$(TARGET_LDFLAGS) \
-                       $(if $(CONFIG_PACKAGE_kmod-mac80211),-lm $(STAGING_DIR)/usr/lib/libnl.a) \
+                       $(if $(CONFIG_PACKAGE_kmod-mac80211),-lm -lnl-tiny) \
                        $(if $(findstring default,$(1)),-lssl -lcrypto)" \
                hostapd hostapd_cli
        $(CP) $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/hostapd_cli $(PKG_BUILD_DIR)/
diff --git a/package/hostapd/patches/130-libnl_update.patch b/package/hostapd/patches/130-libnl_update.patch
new file mode 100644 (file)
index 0000000..51bc58a
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/hostapd/driver_nl80211.c
++++ b/hostapd/driver_nl80211.c
+@@ -29,6 +29,7 @@
+ #include "wireless_copy.h"
+ #include <linux/filter.h>
+ #include <net/if_arp.h>
++#include <linux/rtnetlink.h>
+ #include "hostapd.h"
+ #include "driver.h"
+@@ -45,6 +46,7 @@
+ /* libnl 2.0 compatibility code */
+ #define nl_handle_alloc_cb nl_socket_alloc_cb
+ #define nl_handle_destroy nl_socket_free
++#define nl_handle nl_sock
+ #endif /* CONFIG_LIBNL20 */
+ enum ieee80211_msg_type {