x86: refresh kernel patches
authorFelix Fietkau <nbd@openwrt.org>
Mon, 16 Mar 2015 07:12:31 +0000 (07:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 16 Mar 2015 07:12:31 +0000 (07:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 44810

target/linux/x86/patches-3.18/009-rdc321x_select_embedded.patch
target/linux/x86/patches-3.18/010-rdc_cpu_ident.patch
target/linux/x86/patches-3.18/011-tune_lzma_options.patch
target/linux/x86/patches-3.18/012-export_erase_write.patch
target/linux/x86/patches-3.18/120-panic_on_unrecovered_nmi.patch

index 50f817cb285efd9f453982f2ea5bf40f58f97977..e1599e4f54063c39eb89aee058d107e59a94eb1b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/x86/Kconfig
 +++ b/arch/x86/Kconfig
-@@ -480,6 +480,8 @@ config X86_RDC321X
+@@ -531,6 +531,8 @@ config X86_RDC321X
        depends on X86_EXTENDED_PLATFORM
        select M486
        select X86_REBOOTFIXUPS
index 043c3a31f55f2ed5812cd3f989eaace3c1a5b6aa..64d38c1b7ac3c99d67015fdc7e16d685fed1431e 100644 (file)
@@ -72,7 +72,7 @@
 +
 --- a/arch/x86/Kconfig
 +++ b/arch/x86/Kconfig
-@@ -478,6 +478,7 @@ config X86_RDC321X
+@@ -529,6 +529,7 @@ config X86_RDC321X
        bool "RDC R-321x SoC"
        depends on X86_32
        depends on X86_EXTENDED_PLATFORM
@@ -82,7 +82,7 @@
        select EMBEDDED
 --- a/arch/x86/include/asm/processor.h
 +++ b/arch/x86/include/asm/processor.h
-@@ -137,7 +137,8 @@ struct cpuinfo_x86 {
+@@ -136,7 +136,8 @@ struct cpuinfo_x86 {
  #define X86_VENDOR_CENTAUR    5
  #define X86_VENDOR_TRANSMETA  7
  #define X86_VENDOR_NSC                8
@@ -94,7 +94,7 @@
  
 --- a/arch/x86/kernel/cpu/Makefile
 +++ b/arch/x86/kernel/cpu/Makefile
-@@ -26,6 +26,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32)               += cyrix
+@@ -29,6 +29,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32)               += cyrix
  obj-$(CONFIG_CPU_SUP_CENTAUR)         += centaur.o
  obj-$(CONFIG_CPU_SUP_TRANSMETA_32)    += transmeta.o
  obj-$(CONFIG_CPU_SUP_UMC_32)          += umc.o
index 168c3dd731ed03a7d37d0146269f14d549bef7c4..4bb7b7bf45e9c69ecc3a3d62e0158c43f05aa78d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/Makefile.lib
 +++ b/scripts/Makefile.lib
-@@ -304,7 +304,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -325,7 +325,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^) 
  
  quiet_cmd_lzma = LZMA    $@
  cmd_lzma = (cat $(filter-out FORCE,$^) | \
index 9927384cb8550e9970b809fb99c50fe5ef6108e4..a98525ee502665b17cf6f44dcc93b5bdf56b074b 100644 (file)
@@ -11,7 +11,7 @@
        struct erase_info erase;
 --- a/include/linux/mtd/mtd.h
 +++ b/include/linux/mtd/mtd.h
-@@ -414,6 +414,9 @@ extern void register_mtd_user (struct mt
+@@ -416,6 +416,9 @@ extern void register_mtd_user (struct mt
  extern int unregister_mtd_user (struct mtd_notifier *old);
  void *mtd_kmalloc_up_to(const struct mtd_info *mtd, size_t *size);
  
index 641bb387acb196219d0c3c18b79f8f6af5e2d0ba..0432686cf15a6f08795318462e2a3c965e48713f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mfd/rdc321x-southbridge.c
 +++ b/drivers/mfd/rdc321x-southbridge.c
-@@ -86,6 +86,8 @@ static int rdc321x_sb_probe(struct pci_d
+@@ -85,6 +85,8 @@ static int rdc321x_sb_probe(struct pci_d
        rdc321x_gpio_pdata.sb_pdev = pdev;
        rdc321x_wdt_pdata.sb_pdev = pdev;