iproute2: q_cake: Also print nonat, nowash and no-ack-filter keywords
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 14 Sep 2018 20:52:39 +0000 (21:52 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 15 Sep 2018 07:46:32 +0000 (08:46 +0100)
Pull in latest upstream tweaks:
Similar to the previous patch for no-split-gso, the negative keywords for
'nat', 'wash' and 'ack-filter' were not printed either. Add those as well.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/190-add-cake-to-tc.patch

index 5ed9556043d191a776f925567b5d98881868cc90..1c8e3e66d6174d1da78d82dc19aa6ec72acbb073 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.18.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
index f61168c696f67f72092be8c820299e5a7ec64289..a05d8776eeacd9dfbc6ed9faa624cee38eb0b6d7 100644 (file)
  TCMODULES += e_bpf.o
 --- /dev/null
 +++ b/tc/q_cake.c
-@@ -0,0 +1,801 @@
+@@ -0,0 +1,805 @@
 +// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
 +
 +/*
 +
 +      if (nat)
 +              print_string(PRINT_FP, NULL, "nat ", NULL);
++      else
++              print_string(PRINT_FP, NULL, "nonat ", NULL);
 +      print_bool(PRINT_JSON, "nat", NULL, nat);
 +
 +      if (tb[TCA_CAKE_WASH] &&
 +
 +      if (wash)
 +              print_string(PRINT_FP, NULL, "wash ", NULL);
++      else
++              print_string(PRINT_FP, NULL, "nowash ", NULL);
 +      print_bool(PRINT_JSON, "wash", NULL, wash);
 +
 +      if (ingress)
 +      else if (ack_filter == CAKE_ACK_FILTER)
 +              print_string(PRINT_ANY, "ack-filter", "ack-filter ", "enabled");
 +      else
-+              print_string(PRINT_JSON, "ack-filter", NULL, "disabled");
++              print_string(PRINT_ANY, "ack-filter", "no-ack-filter ", "disabled");
 +
 +      if (split_gso)
 +              print_string(PRINT_FP, NULL, "split-gso ", NULL);