kernel: Remove 2FS_FS_XATTR and F2FS_STAT_FS symbols from target configs
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 10 Oct 2020 10:02:02 +0000 (12:02 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 11 Oct 2020 14:38:16 +0000 (16:38 +0200)
This config option was moved to the generic kernel configuration.

Fixes: ab1bd576562b ("kernel: move F2FS_FS_XATTR and F2FS_STAT_FS symbols to generic")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/fs.mk
target/linux/apm821xx/sata/config-default
target/linux/bcm27xx/bcm2708/config-5.4
target/linux/bcm27xx/bcm2709/config-5.4
target/linux/bcm27xx/bcm2710/config-5.4
target/linux/bcm27xx/bcm2711/config-5.4
target/linux/mediatek/mt7623/config-4.19
target/linux/mediatek/mt7623/config-5.4
target/linux/uml/config/i386
target/linux/uml/config/x86_64

index cfce929c0c5b644098a3485242099432107b73af..0abd5285db48b30aab0d6f2c5dcea7965d7a1f60 100644 (file)
@@ -208,8 +208,6 @@ define KernelPackage/fs-f2fs
   DEPENDS:= +kmod-crypto-hash +kmod-crypto-crc32 +!LINUX_4_19:kmod-nls-base
   KCONFIG:= \
        CONFIG_F2FS_FS \
-       CONFIG_F2FS_STAT_FS=y \
-       CONFIG_F2FS_FS_XATTR=y \
        CONFIG_F2FS_FS_POSIX_ACL=n \
        CONFIG_F2FS_FS_SECURITY=n \
        CONFIG_F2FS_CHECK_FS=n
index daa4646bffe0b59085a85f3dd324440e2f3eb987..15aed962d5d28a2ba51e687a19ae58e7dbd7ceb4 100644 (file)
@@ -18,7 +18,6 @@ CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
 # CONFIG_F2FS_FS_SECURITY is not set
-CONFIG_F2FS_STAT_FS=y
 CONFIG_SCSI=y
 CONFIG_BLK_DEV_SD=y
 CONFIG_GPIOLIB=y
index 3c4dc98eb0c3899f0262b34174dd45f80f1407ef..c560ff04ad50de7e9de2d6a160f6d5d19c2edb42 100644 (file)
@@ -159,7 +159,6 @@ CONFIG_EXT4_FS=y
 CONFIG_EXT4_FS_POSIX_ACL=y
 CONFIG_EXT4_FS_SECURITY=y
 CONFIG_F2FS_FS=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_BCM2708=y
 CONFIG_FB_CFB_COPYAREA=y
index f76f3aae712c7778eac3159d0f69845fead2de39..017f3eb0adfbfa14a91301857109bf53c0eaf5ff 100644 (file)
@@ -205,7 +205,6 @@ CONFIG_EXT4_FS=y
 CONFIG_EXT4_FS_POSIX_ACL=y
 CONFIG_EXT4_FS_SECURITY=y
 CONFIG_F2FS_FS=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_BCM2708=y
 CONFIG_FB_CFB_COPYAREA=y
index 68ef51ca6ff83cf11a3a20042e432796f8b00590..a011e2f213419b12f25c17fa7d5e77db33d97832 100644 (file)
@@ -248,7 +248,6 @@ CONFIG_EXT4_FS=y
 CONFIG_EXT4_FS_POSIX_ACL=y
 CONFIG_EXT4_FS_SECURITY=y
 CONFIG_F2FS_FS=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_BCM2708=y
 CONFIG_FB_CFB_COPYAREA=y
index 5561051e97163ef96fc301a1b34292bd93424b32..ee391ff5be551964526cd1aa6315dfc3d3ea66ec 100644 (file)
@@ -253,7 +253,6 @@ CONFIG_EXT4_FS=y
 CONFIG_EXT4_FS_POSIX_ACL=y
 CONFIG_EXT4_FS_SECURITY=y
 CONFIG_F2FS_FS=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FB=y
 CONFIG_FB_BCM2708=y
 CONFIG_FB_CFB_COPYAREA=y
index 56ae95cc3142a489f813bf7497e12dda6730c4a2..edf285c45a7c6643c1aea2724c0094563199f5ea 100644 (file)
@@ -176,8 +176,6 @@ CONFIG_EXT4_FS=y
 # CONFIG_F2FS_CHECK_FS is not set
 CONFIG_F2FS_FS=y
 # CONFIG_F2FS_FS_SECURITY is not set
-CONFIG_F2FS_FS_XATTR=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y
 CONFIG_FREEZER=y
index 28760e6003abecd73af0337bd2817e02aaf81a94..a6b32ce33bf49c22b7214be1c1d9d56f66dd6c68 100644 (file)
@@ -184,7 +184,6 @@ CONFIG_EINT_MTK=y
 CONFIG_ELF_CORE=y
 CONFIG_EXT4_FS=y
 CONFIG_F2FS_FS=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y
 CONFIG_FREEZER=y
index 94a972792a8d70b5f47d8a7834923122a5389148..5a066ac6a34f88c81fa7f7f6f121779450121938 100644 (file)
@@ -30,7 +30,6 @@ CONFIG_DNOTIFY=y
 # CONFIG_EARLY_PRINTK is not set
 CONFIG_EXT4_FS=y
 CONFIG_F2FS_FS=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FAILOVER=y
 CONFIG_FS_IOMAP=y
 CONFIG_FS_MBCACHE=y
index 988ef22faf650f668391159ebd54c2363bcd18b7..d3b3704f6c9acbb8f110094c810b8f6d25080d8b 100644 (file)
@@ -32,7 +32,6 @@ CONFIG_DNOTIFY=y
 # CONFIG_EARLY_PRINTK is not set
 CONFIG_EXT4_FS=y
 CONFIG_F2FS_FS=y
-CONFIG_F2FS_STAT_FS=y
 CONFIG_FAILOVER=y
 CONFIG_FS_IOMAP=y
 CONFIG_FS_MBCACHE=y