netifd: add support for the new ar8xxx MIB counters settings
authorPetr Štetiar <ynezz@true.cz>
Sat, 13 Apr 2019 08:31:44 +0000 (10:31 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 20 May 2019 19:19:48 +0000 (21:19 +0200)
Commit "generic: ar8216: add mib_poll_interval switch attribute" has added
mib_poll_interval global config option and commit "generic: ar8216: group
MIB counters and use two basic ones only by default" has added mib_type
config option.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/network/config/netifd/Makefile
package/network/config/netifd/files/etc/init.d/network

index 8b641ca139711ea1c4c1425f5badb62ed819057c..0ea928544a0bb7f92021af7c1ab478b4201d2c46 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
index 99d9f6582fb8b7002b48cd280a73521b9fd66450..2321a309a5ceabea034cf567d8b80850ff4f3b59 100755 (executable)
@@ -115,7 +115,9 @@ validate_switch_section()
                'name:string' \
                'enable:bool' \
                'enable_vlan:bool' \
-               'reset:bool'
+               'reset:bool' \
+               'ar8xxx_mib_poll_interval:uinteger' \
+               'ar8xxx_mib_type:range(0,1)'
 }
 
 validate_switch_vlan()