kernel: bump 4.14 to 4.14.101
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 15 Feb 2019 10:09:09 +0000 (11:09 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 15 Feb 2019 20:53:27 +0000 (21:53 +0100)
Refreshed all patches.

Fixes:
- CVE-2019-3819

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch

index 80f78b2b6bed2c992cb56bba04158b6b088d1fd7..af7b5cd8a76385fc3bf5136add6c2eaa37782434 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .134
 LINUX_VERSION-4.9 = .158
-LINUX_VERSION-4.14 = .99
+LINUX_VERSION-4.14 = .101
 LINUX_VERSION-4.19 = .21
 
 LINUX_KERNEL_HASH-3.18.134 = 36bdd04cab3b6c824a4b7e32ae02503f437e0916d5a4ff04c90aa22da2749c2f
 LINUX_KERNEL_HASH-4.9.158 = 8c8a69f590e6f1103c949b45ff1bfd42c705388321f75e1520be3556f81375ef
-LINUX_KERNEL_HASH-4.14.99 = 8ff98caed5b20b733dedcbe99559d71a0e09e239c0c2488b3fd799c96489eb0a
+LINUX_KERNEL_HASH-4.14.101 = 142ff7c51b001c66e9be134fcec2722f9a47b89879a18e6f65b09b4585cdb69a
 LINUX_KERNEL_HASH-4.19.21 = db08ede726fe410da274e1e98f0de2aed9ff4b0e0b63a89e5928bef46998bbc1
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 90bb6426e49a6b7bc68fa5e12734325823cd9400..a5a5f8b29a4255017e7bc584b8385bc896fe5f27 100644 (file)
@@ -263,7 +263,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  int bond_set_carrier(struct bonding *bond);
 --- a/net/batman-adv/soft-interface.c
 +++ b/net/batman-adv/soft-interface.c
-@@ -872,7 +872,8 @@ free_bat_counters:
+@@ -874,7 +874,8 @@ free_bat_counters:
   * Return: 0 if successful or error otherwise.
   */
  static int batadv_softif_slave_add(struct net_device *dev,